Search the Community

Showing results for tags 'scope'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments and the WaveForms software
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 24 results

  1. Hi, Can anyone tell me if it is possible, from within the <Scope/Math channel/Custom scripting> environment to access instrument objects like Wavegen1, Logic1, Logger1, ... and their sub-objects? And if it's possible, how to do it? Thanks in advance for your help. Kind regards.
  2. Is it possible to decode scope data using one of the "protocols"? I often need to analyze scope data as inverted UART data (e.g an RS-232 async serial signal).
  3. renesas_an1560_making_noise_measurements_pgs_1-3.pdfI have a noise test setup that is measuring the en noise of jfets and is gaining it by 1000x to the AD2. What tools exist in the AD2 - likely either scope with FFT or the SA where I can get reported the rms voltage value over frequency and the number of samples taken for the RMS. I don't want pk-pk as it requires more work and samples to be meaningful to the analog circuit designer - me. Please provide a best practice method as I am struggling at this time. An alternate can be to move to another piece of test equipment if this is
  4. Hi, I'm working on a WaveForms script which would be able to generate chart with the frequency profile of a liquid. For this, I need to use a Wavegen and a Scope: first I need to set the generator to a certain frequency and then I'd like to check the power of that signal on the scope. Between the probes of the generator and the scope there will be the liquid I would like to test. I created a basic script to step from 1 Hz to 150 Hz, check that signal with the scope, repeat this loop 5 times, and calculate the min, max and average values at each frequency. Although the script w
  5. Hello, My name is Oliver and I am a research assistant at the Technische Universit├Ąt Ilmenau in Germany. Among other things, I teach fundamentals of power electronics for mechatronics bachelor. Last year I started with a lab course where I use eleven Electronic Explorer Boards. It makes a lot of fun for me and the students. From time to time it comes to an error regarding the scope. After connecting the board, starting the WaveForms application and opening the scope all four channels show -20 V. They stick there regardless what is connected to them. Usually disconnecting the board a
  6. Hi I am using analogIN record for acquisition of the signal. The problem I encountered is the fact that the acquired signal is randomly delayed in with repetition of the measurements. (see fig attached, where a same measurement is performed several time. Starting point always differ). Is there a particular reason for it and is there an elegant solution except the dirty one which compares delays of different measurements and performs the delay shift operation. Many thanks in advance. I used AnalogIn_Record.py from the example library and analog discovery 2. thanks & cheers,
  7. Hello again! I'm trying to use the AD2 to act as both a signal source (wavegen1) and a measurement (scope1) device for the purpose of tracking conduction delay of the signal. Currently, I simply have the wavegen1 connected directly to scope1 with 3 cycles of a sine wave being put out. I am aware of the measure command to find the maximum on my scope1 but I was wondering if there was a way to find N (3 in my case) maximums AND find the corresponding times with respect to the timing of wavegen1? I plan to assume the timing of the wavegen1 is relatively accurate to my input frequency and c
  8. Hello, I have found that the Analog Discovery 2 scope has input sensitivity scales between 500uV to 5V/div. What is the specification of the scope included in the Electronics Explorer board? Thanks Paul
  9. Hi, I am trying to capture a periodic negative pulse which duration is less than 10 us. If I set trigger to pulse, condition to negative and Lcondition to more than 5 us, the trigger works as expected and a negative pulse of approx 5.5 us is captured. However, when I set the Lcondition to less than 10 us (5.5 us is obviously less than 10 us) it won't trigger.
  10. I am using the Analog Discovery 2, and the latest version of WaveForms, 3.7.5, on Mac OS 10.13.3. I find that triggering the Scope on Channel 1 or Channel 2 works fine, but trying to trigger on either Wavegen channel does not give me any triggers. The same is true when trying to trigger off a pattern. The interface seems quite intuitive, but I must be missing something because I cannot get the wave form generator and the scope to synchronize, unless I trigger normally on one of the scope channels. Is there some documentation on how to do this? Thanks!
  11. Could someone please tell me whether it is normal for a 4.5Vpp signal to show on the AD2 scope (with daughter board and real probe) as a 4.0Vpp signal when at 2V/div? If not, any advice for troubleshooting? Additional information: The ground clip is grounded properly. It doesn't change the signal when I connect the ground wire to my circuit ground as well. 20Vpp shows as 17.5Vpp at 5V/div.
  12. I'm currently trying to synchronize analog pulses on both AWGs with digital pulses, and simultaneously run both analog scopes and the digital scope. I am trying to trigger all outputs and all scope acquisitions to happen simultaneously with a single PC-Trigger source using the SDK. First question: Why isn't there an AnalogInTriggerSlopeSet function? (You can set the TriggerSlope to rising edge for AnalogOut, DigitalOut, and DigitalIn). Without an AnalogInTriggerSlopeSet function, how do you set the AnalogInTrigger to respond to the same signal as the other three? Second Question: W
  13. Hi all, Most likely this question has already been answered, but I cannot find any info. Is it safe to feed the AWG of the Analog Discovery to the scope of the same device? can this somehow cause any damage to the AD2?
  14. Hi all, I've run into an unexpected problem. Issue It seems that when I use both scope channels within the same circuit (at least for this circuit) I get tons of 60Hz noise and its harmonics. Using a single channel does not generate this kind of noise. Setup I am using a 3 channel DC supply plugged into 60hz wall power that feeds my breadboard circuit in two areas. My breadboard circuit is a simple non-inverting op-amp whose input signal comes from a constant current source excited thermistor. The gain is ~ 30 V/V. I'm using the Analog Discovery 2. Detai
  15. Hi Everyone, I've been using "Scope1.Channel1.alldata" to collect Channel data from the scope, but is there a function to collect the "Time" data? Best Regards, Nick
  16. Hello all, I am trying the measure a variable frequency signal, is it possible to create a custom scope channel that will display the most prominent frequency? If a scope channel is not possible, is there a way to continuously log the frequency over time? Currently, I am only able to get one frequency reading per acquisition using the logging tool and exporting the 'measurements' source.
  17. I'm running waveforms 2015 3.5.4 and got a bug/request. When changing the timebase, the position should not change. When I use the scroll the wheel or the timebase pop-up the actual position of the trigger point moves around in the scope graph window, this is very frustrating. Once you set the trigger x position, it should never move. Thanks.
  18. After I collect data using the scope, I'm trying to write the script to create an array with such data so that I can further analyze it. However, I noticed that the "Scope1.Channel1.data" (7693 samples) outputs different data from that shown in the table on the Scope tab -> View -> Data (8192 samples). Any recommendations on how to output the data displayed on the oscilloscope? PS: On the "WaveForms 2015 Reference Manual" it is said that Scope1.Channel1.checked obtains the data array, but this is false since ".checked" returns true or false.
  19. Hello, Just a suggestion: Give the users a preference setting to enable warnings when an action is about to delete/reset data in the scope or logger windows. E.G. I want to use the logger to record a DC voltage over a very long time (hours). If I change certain settings like the time/division the plot is reset automatically with no warning and the data I have been recording is lost. I would like to be able to save that data before it is lost. A dialog that warns that data is about to be lost and gives the user the option of exporting it would be very useful. I know it could be a
  20. Hello All, I am trying to acquire a waveform from one of my terminal of the ESP8266 microcontroller (GPIO0). I should be expecting a signal from the crystal at this terminal which is oscillating at 26 MHz. Can anybody let me know the correct settings to acquire the signal of 26 Mhz? The following are the steps that I performed: 1. Go to settings--> Device Manager --> select 2x 16K scope 2. Then click the settings (gear symbol) on the time settings box on the right side of the window 3. Here, I select Range Mode = Division Mode, Rate = 100 MHz, Samples = Default I ha
  21. Hello, I want to find a maximum value during a period with a script on the scope. I have done that but the result is wrong: Scope1.single() Scope1.wait() Scope1.Time.Base.value = (1/freq) var data = Scope1.Channel1.data data.forEach(function(sample){ Vin_Max = Math.max(sample); }) print("Vin_Max: ",Vin_Max,"V") Do you have an idea? Thank in advance.
  22. Is persistence mode available in Waveforms 2015 (3.1.5) for Scope?
  23. Can we use mouse to select (click and drag) a portion of the waveform shown in Scope while it is running?
  24. Hi, I am running Waveforms 3 beta on my macbook and i have encounterd a problem. When trying to capture and voltage impulse from my accelerometer the Scope never reacts to it. I have set Mode to normal, with condition: rising and level:0.2V And it never captures anything. I have checked the single acq. with the waveform generator, and when using that as an input it works flawless. What could be my error here?