Search the Community

Showing results for tags 'pmod-shield'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. As I work with the chipKIT WF32 and the WiFIre, I find that making external connections to these processor boards is not as convenient as they are for the chipKIT Pro MX7 that has Pmod connectors JA through JF. Additionally there are limited pins for taking 3.3V/5V and ground off board. I can only assume that these chipKIT boards were always intended to be used with a shield of some sort. If Digilent makes IO shields specifically for the WF32 and WiFire, please advise. Meanwhile, I find the the Pmod Shield-Uno can be used to provide standard Pmod connections provided a few modifications are made. 1. The bottom side female connectors for JP6-JP8 must be removed because the USB connector J13 on the Wf32 and WiFire are in the way. This is easily done by gently bending the female connectors on the bottom of the Shield-Uno back and forth until they break off at the surface of the PCB. The schematic diagram for the Pmod-Shield does not show a connection for the center pin of JP6 and JP8. Can I assume that since JP6 and JP8 do not feed through to the WF32 or the WiFire that A04/A18 and A05/A19 are not functional? 2. I observed that pins 1 and 2 of J3 on the WF32 / WiFire have no connection to J5 on the Pmod-SHield. This appears not to be an issue since J3:1 is not connected and J3:2 has jumper to J3:4. 3 J6 of the WF32 / WiFire has no connection to the Pmod-Shield making connections to I2C2 unavailable. I could not find a secondary connection for SCL2 and SDA2. 4. Although the majority of the processor programming is done in the Arduino IDE environment using the serial port, there are times that debugging with the MPLAB X IDE is beneficial. Hence, I permanently soldered a single row right angle 6 pin header in JP2. This allows me to slip on and off a chipKIT programmer without removing the shield. Do you for see any problems such as RFI emissions? 5. Reading through the Pmod Shield-Uno users manual I see that the signal names for JA and JB are the same. The chipKIT pin numbers appear to be correct. Digilent should update the users manual.