Search the Community

Showing results for tags 'mx7'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 7 results

  1. Howdy. I have what I think is a fairly basic question: Which (non-FPGA) processor boards support Pmod modules? Is there any chance to see a table that shows each of the current ARM and PIC32 processor boards down a left-hand column and then the quantity of each of the Pmod ports (of each different configuration) on the middle of the chart? Thanks
  2. I am trying to load my first program on to my new MX7 chipkit pro. I'm using the MX7_blink example written by Christian Fatu and Michele Yu. Using MPLAB X IDE I am getting errors during debugging, undefined reference to 'PORTWrite' and undefined reference to 'PORTSetPinsDigitalOut'. I am a rookie C coder, do these need to be declared as some type of functions above the main() ?
  3. Good day community, I'm busy working on a project with a Cerebot MX7 Pro. It's me now noticed that the board so every 5 to 10 minutes restarts. This is not intended by me. I would be happy to send you my project to be ruled by an error on the board. I am using MPLAB X 3.15 with the XC32 1.40 on the PowerDebug USB connection. I hope for an insightful answer or input. Test02.zip
  4. Hi, i'm trying to put together the ETHERNET demo example from the digilent website under the MX7 documents area (schematics, BLINKLED example,,etc... I downloaded the demo and try to install it into the MPIDE environment. While compiling the associated libraries, i get the following message: "The library chipKit network and USB libs-20150115 cannot be used. Library names must contain only letters and numbers) ascii only and no spaces..." The library contains several directories and files. Wich files need to be modified? Anyone has tried this demo example? Rob
  5. Hello Guys! I hope you can help me with some doubts. I have a code that I use the ADC, TIMER and ETHERNET modules, when I try to compile it some erros are reported, as follows: C:/Users/MyName/Desktop/mpide-0023-windows-20140821/hardware/pic32/compiler/pic32-tools/bin/../lib/gcc/pic32mx/4.5.2/../../../../pic32mx/bin/ld.exe: small-data section exceeds 64KB; lower small-data size limit (see option -G) chipKITEthernet\utility\DNS.c.o: In function `DNSEndUsage': C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:208:(.text.DNSEndUsage+0x0): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:211:(.text.DNSEndUsage+0x20): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:213:(.text.DNSEndUsage+0x38): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' chipKITEthernet\utility\DNS.c.o: In function `DNSResolve': C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:262:(.text.DNSResolve+0x48): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:256:(.text.DNSResolve+0x74): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' chipKITEthernet\utility\DNS.c.o: In function `DNSIsResolved': C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:358:(.text.DNSIsResolved+0x0): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:369:(.text.DNSIsResolved+0xac): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:380:(.text.DNSIsResolved+0xfc): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:384:(.text.DNSIsResolved+0x114): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:388:(.text.DNSIsResolved+0x124): relocation truncated to fit: R_MIPS_GPREL16 against `no symbol' C:/Users/MyName/Documents/mpide/libraries/chipKITEthernet/utility/DNS.c:423:(.text.DNSIsResolved+0x1f4): additional relocation overflows omitted from the output collect2: ld returned 1 exit status I'm using the timer with interruption enabled, the ADC is used to scan 6 chs and the Ethernet to send the data to my computer, somebody coud help me? Regards.
  6. Mike Brooks said: Hi Several years ( 2 ) ago I purchased a Cerebot MX7ck board. The board works fine, but because of the time since I've used this board I can't remember or figure out how to download software to it. It has an ICSP prt which is not to be used, so my guess it's loaded through a serial port or USB port. Can you please tell me what I need to load a hex file. I'm asuming MPLAB X but how do I load the hex file to the board. Thx for your help in advance. Cheers Mike....
  7. Dear All, Have a ChipKit MX7 board . Using MPLAB X 2.26 XC32 compl .. Code compiles OK . All jumpers set for MPLAB X ... JP11 out .....J3(DBG)...Connected to J15 (USB) when I try to debug the following messages come up : Connecting to MPLAB Licensed Debugger...Firmware Suite Version.....00.00.00 *Firmware type..............Unknown Firmware Type <prod>chipKIT Pro MX7 by <man>Digilent Downloading Firmware...Downloading RS...RS download completeProgramming download...Connection Failed. DO not know what to do... please help Alex