Search the Community

Showing results for tags 'mplab'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. I'm pretty confident I am following instructions to the letter but it's possible I am doing something wrong. But any assistance here would be great. MPLab X (5.20), XC32 (2.10), Arduino 1.8.10, Chipkit Library 2.10, Importer 1.0.6 (All the latest), Target Board is Pro MX 7. The latest importer states these versions should be acceptable because of the whole "or later" caveat. I've added photos showing I'm my directories (pretty sure they're all pointing to the correct location I'm trying to upload the Chipkit Wire - Master Reader .ino file. I select the Pro MX 7 in Arduino IDE, open the sketch, and save it to a different folder. Is that possibly the wrong step? Just spit balling. Is there some grand secret to making this work that I don't know and the internet refuses to tell us? Here's what that last photo says: java.lang.RuntimeException: java.lang.NullPointerException at com.microchip.mplab.nbide.embedded.chipkit.importer.ArduinoBuilderRunner.preprocess(ArduinoBuilderRunner.java:109) at com.microchip.mplab.nbide.embedded.chipkit.importer.ArduinoBuilderRunner.preprocess(ArduinoBuilderRunner.java:84) at com.microchip.mplab.nbide.embedded.chipkit.importer.ChipKitProjectImporter.preprocessSourceProject(ChipKitProjectImporter.java:307) at com.microchip.mplab.nbide.embedded.chipkit.importer.ChipKitProjectImporter.execute(ChipKitProjectImporter.java:174) at com.microchip.mplab.nbide.embedded.chipkit.wizard.ImportWorker.importChipKitProjectFiles(ImportWorker.java:275) at com.microchip.mplab.nbide.embedded.chipkit.wizard.ImportWorker.createProjectFromChipKit(ImportWorker.java:189) at com.microchip.mplab.nbide.embedded.chipkit.wizard.ImportWorker.invokeImporterTasks(ImportWorker.java:144) at com.microchip.mplab.nbide.embedded.chipkit.wizard.ImportWorker.doInBackground(ImportWorker.java:94) at com.microchip.mplab.nbide.embedded.chipkit.wizard.ImportWorker.doInBackground(ImportWorker.java:72) at javax.swing.SwingWorker$1.call(SwingWorker.java:295) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at javax.swing.SwingWorker.run(SwingWorker.java:334) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748) Caused by: java.lang.NullPointerException at com.microchip.mplab.nbide.embedded.chipkit.importer.ArduinoBuilderRunner.lambda$findMainLibraryPaths$0(ArduinoBuilderRunner.java:191) at java.lang.Iterable.forEach(Iterable.java:75) at java.util.Collections$UnmodifiableCollection.forEach(Collections.java:1080) at com.microchip.mplab.nbide.embedded.chipkit.importer.ArduinoBuilderRunner.findMainLibraryPaths(ArduinoBuilderRunner.java:186) at com.microchip.mplab.nbide.embedded.chipkit.importer.ArduinoBuilderRunner.preprocess(ArduinoBuilderRunner.java:99) ... 14 more
  2. Hi, I got a new Digilent Pro MX7. Right now i am trying to install MPLAB X-v3.65 and XC32-v1.31 compiler. But when I plug the board to PC through USB and create a new project, select correct device (Family: 32-bit MCUs PIC32, Device: PIC32MX795F512L) and hit NEXT, I can't see the serial number of my board shown at Select Tool. I have been struggling for the whole day, am I using the wrong version of the software? I tried the newest one (MPLAB X-v5.15) too, but still have the same problem.
  3. I have the dividend peripheral model SonarMax. I am using it with a MPLab and the MX7 Microconroller board (pic32). I just need an example on how to read the distance from MaxSonar.
  4. hi there, I have a question about code optimization with MPLAB/gcc. I have a part of code which is not working while optimization is set to level 1. So I added this pragma: #pragma optimize 0 //Some code... #pragma optimize 1 Now it is working if I set optimization to level 1 in the MPLAP gcc preferences for this project. But my question is, what is the gcc doig, if I set optimization to level 0 I the gcc settings? Is it in this case anyways doing optimization with level 1 after using this pragma? How long is this pragma setting valid, only for this .c or .h file, or for the complete project, ...? Or how could I manage this, to set the optimization level back to the level it had before setting it to 0?