Search the Community

Showing results for tags 'impedance analyzer'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 12 results

  1. I am a new user and am trying to understand what all the knobs in this program are for. I have an Analog Discovery 2 + Impedance Analyzer board. In `impedance.html` of the documentation, it talks about series resistance/reactance and parallel resistance/reactance. However, it never actually defines what these address. The same thing goes for the Meter's parameters for series model and parallel model. What do these terms refer to? Is it some hardware configuration within the AD2? There seems to be no documentation of these terms, despite me searching through this forum. Thank you in advance for your help! -James
  2. Hello everyone, I have problem with impedance data exporting from AD2 and can't find-out the solution. I wasn't lucky to find people who had the same problem. Problem: exporting Impedance measurement data to CSV I got empty rows. Graph looks correct. All data point refer to only one number, so results only horizontal line. I had the same problem with older version WaveForms and from first was thinking that update solved my problem, but it still occurring. I had idea that I save to much reference lines in Workspace, but problem accures with 6 reference lines too. System: MacOS High Sierra. WaveForms 3.10.9 64-bit Qt5.6.3 macOS 10.13 If anyone has any ideas please let me know the solution.
  3. Afternoon, all I have a question about the digital I/O interface between the Analog Discovery 2 oscilloscope and the Impedance Analyzer board. I am attempting to emulate the Waveform software impedance measurement screen for the purposes of First, I was able to use the LabVIEW drivers provided by the manufacturer to generate 3.3 volts for as an output measured between the pin and ground. Per the schematic provided for the Impedance analyzer board, the digital I/O pins are used to channel through the various resistors utilized to measure whatever load is applied between the oscilloscope pins. However, when I use the Waveform software and select Adaptor board in the Impedance screen, I am unable to measure any change in the digital I/O which are used to switch the resistor values 1M, 100K, 10k, 1k, 100 and 10 ohms. I used the same meter I used to verify that I was getting a voltage output between the digital I/O pins and checked measured between the pin and ground, but was unable to read anything. I also used an oscilloscope to see if I was missing a momentary pulse that I wasn't seeing on Also, there is nothing wrong with the board or the oscilloscope since I can hear the switches clicking on my Impedance Analyzer board when I select different resistor values and also measure the values between the Oscilloscope 2 and ground. It is just that I can't measure the digital I/O voltage when I am actually using them Therefore, my question is in regard to verifying the digital I/O being applied to the Impedance Analyzer board and whether or not I am measuring across the pins (the output pin and ground) or if there is some other verification process in order per the waveform software which I am not privy to in the selection process. Please advise at your earliest convenience. I am uploading the diagrams I am utilizing for my testing. Let me know if you have any follow up question in regards to my query. Thanks as always, Forrest Palmer analog_discovery_impedance_analyzer_sch (1).pdf
  4. Hello forum, I am a master student with a project involving Impedance measurements. I was thinking about buying the Analog Discovery 2 with the Impendance Analyzer but i would like to use BNC probes and i was wondering if i could use the BNC adapter to take the measurements instead of the imput conections provided by the impedance analyzer. Thanks in advance.
  5. Using Waveforms 3.9.1 under Mac OS 10.14.2, in DEMO mode with Analog Discovery 2 being emulated, selecting the wrench icon for the compensation menu results in the program hanging and needing to be killed. The same action when an Analog Discovery 2 is attached performs correctly—this seems to be just an error in the emulation in DEMO mode.
  6. Dear all, The impedance analyzer module for the AD2 works quite well with the Wafeform software on my Windows 10 PC. However, it would be great to be able to use the module with e.g. a python program and the SDK. Is there an example in python or c how to control the relays and gain of the module ? Regards, Rudolf Sprik
  7. In Waveforms 3.8.17 (beta), I have encountered a bug in the impedance analyzer when the offset voltage is not zero. I was measuring the impedance of 10µF capacitors with the adapter board at 100Ω, and I got perfectly fine readings when I used amplitude=1V, offset=0V. But when I switched to using amplitude=1V, offset=4V, the impedance was reported as essentially infinite (dropping down to maybe 100MΩ around 100kHz). I got this result with several different capacitors, so it is unlikely that poor connections were responsible. The short and open compensations were redone for the new offset, and seemed to be reasonable. Providing a DC offset when testing electrolytic capacitors is essential, and a DC offset is also useful for determining the voltage dependance of ceramic capacitors, so fixing this bug seems to be fairly important.
  8. I do not understand the algorithm being used for reporting "resistor too high!?" in the impedance analyzer. It seems to pop up whenever the phase is close to 0°, which makes no sense to me. The resistor is too large when the magnitude of impedance measured is less than about 0.01 times the reference resistance—the phase isn't really a relevant parameter. A slightly more sophisticated algorithm might look at the voltages of the two measurements and report the resistance being too large or too small when the relevant voltage (across the resistor or across the DUT) gets down to only a few bits in the ADC. Speaking of voltages—shouldn't the impedance analyzer warn the user when too much current is being asked of the function generator? With a 10Ω reference resistor, the short compensation calls for 100mA/V, but the output stage of the function generator is limited to about ±35mA so even the default ±1V is too much amplitude. Detecting that the voltage measured does not match the voltage requested should not be very difficult.
  9. There is a minor bug in Waveforms 3.8.2 in the Impedance Analyzer: the metadata for probe resistance and capacitance seem to be swapped: #ProbeCapacitance: 1.04e+06 Ω #ProbeResistance: 4.3e-11 F Also, the metadata does not include the excitation (amplitude and offset). I would check the beta release of newer versions, but there doesn't seem to be a beta for the Mac OS X, just Windows and Linux.
  10. Hi, I'm trying to measure the capacitance of a sensor, and am using the impedance analyzer tool to do so. If I do not connect anything I notice it sees a 22pF parallel capacitance. Is this because the program does not automatically compensate for the internal 24pF capacitance? EDIT: I am using the Analog Discovery 2 with Waveforms 3.8.2
  11. I have a suggestion for the user interface for the impedance analyzer: remove the terminology "resistor first" or "load first" as first/second is rather meaningless in a circuit. Instead have options ch1 R+load ch2 load ch1 R+load ch2 R ch1 R ch2 load ch1 load ch2 R The third and fourth options would allow better measurements on the Analog Discovery 2, as the relevant voltages would be measured directly, rather than relying on the subtraction of two measurements. Using the difference increases the noise and does not allow increasing the gain when the voltage difference is small.
  12. Why does the impedance analyzer only allow 10Ω, 100Ω, 1kΩ, 10kΩ, 100kΩ, and 1MΩ reference resistors? I might have a precision 510Ω resistor that I want to use for a reference. Or, as happened for me today, I might want to use a 1Ω resistor as a reference (I was trying to determine the saturation current for an inductor, so I needed a large DC current, plus a small signal to measure impedance with.) I added an external transistor to provide gain from the function generator, but the 10Ω constraint meant that I couldn't raise the current much without hitting voltage limits. (I'll have to use the network analyzer and do my own fitting, rather defeating the advantage of the impedance analyzer) I found the impedance analyzer a bit non-intuitive to use and almost completely undocumented. It is a bit annoying that compensation needs to be redone any time the sweep is changed, and there there is no way to store a number of different compensation sets, switching between them as needed. I was also wondering why the impedance analyzer used a shared ground, rather than taking advantage of having differential inputs to measure the voltage across the resistor and the unknown impedance separately. Using the differential channels, one can have a larger difference in |Z| between the reference and the unknown, since you don't have to compare R with R+Z, but only with Z.