Search the Community

Showing results for tags 'deviot'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi All, I have tried to use chipkitcan library from Sublime Deviot. Deviot uses platformio as build platform. I have been able to install the microchip legacy peripheral libraries in platformio and so able to compile, but I run into linker issues, symbols not found. The linker scripts for my architecture are properly found but it sounds to me that the static library for the peripheral is not found. I have verified that the linker script contains the OPTIONAL("libcmh_peripheral.a") and the same for the architecture specific linker and library. This works fine with IMPDE and with Arduino IDE (after intalling peripheral libraries). Is there anything in the compiler or IDEs that is hardcoded to find the static libraries? any environment variable or so? Thanks