Search the Community

Showing results for tags 'bug'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments and the WaveForms software
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 14 results

  1. With WaveForms for Windows in docking mode, keyboard shortcuts don't respect focus. Instead of being delivered to the currently focused panel only, the keystrokes are sent to any random panel with a matching shortcut. Consider the following layout: [Supplies | Logic] ------------------ [Protocol | Script] With the Script panel in focus I'd expect Alt+F to open the Script panel's File menu, but it instead goes to Supplies. If I hit Esc and try again it now goes to Protocol, then to Script, then to Logic, and so on. What's more alarming is that if you stack some of the panels,
  2. Using Waveforms 3.9.1 under Mac OS 10.14.2, in DEMO mode with Analog Discovery 2 being emulated, selecting the wrench icon for the compensation menu results in the program hanging and needing to be killed. The same action when an Analog Discovery 2 is attached performs correctly—this seems to be just an error in the emulation in DEMO mode.
  3. In Waveforms 3.8.17 (beta), I have encountered a bug in the impedance analyzer when the offset voltage is not zero. I was measuring the impedance of 10µF capacitors with the adapter board at 100Ω, and I got perfectly fine readings when I used amplitude=1V, offset=0V. But when I switched to using amplitude=1V, offset=4V, the impedance was reported as essentially infinite (dropping down to maybe 100MΩ around 100kHz). I got this result with several different capacitors, so it is unlikely that poor connections were responsible. The short and open compensations were redone for the new of
  4. Hi, I recently discovered that the wrong scan codes are sent for certain keys. This is tested with my own PS2 keyboard controller, and the same behaviour is present with the official demo: https://reference.digilentinc.com/learn/programmable-logic/tutorials/nexys-4-ddr-keyboard-demo/start I have tested two keyboards: One Logitech K120, and one Microsoft comfort curve 3000. The following behaviour is exhibited: Left arrow set 2 scancode should be: E0 6B / E0 F0 6B. Actual: 6B / F0 6B Up arrow set 2 scancode should be: E0 75 / E0 F0 75. Actual: 75 / F0 75 Down arrow set
  5. Hi, I just added a function generator amplifier to my AD2, and i recognized the following: - When everything is hooked up (function gen + 21W lamp for testing) and i start waveforms, it seems that the output of the AD2 goes unwanted high. (There is some current drawn from the power supply at the same time) - The same thing happens: -when you click in the close window button on the top rigth corner when the window pops up that asks you to save the current workspace. but in this case the current drops much slower. (as seen on the power supply) Waveforms Ver
  6. There is a minor bug in Waveforms 3.8.2 in the Impedance Analyzer: the metadata for probe resistance and capacitance seem to be swapped: #ProbeCapacitance: 1.04e+06 Ω #ProbeResistance: 4.3e-11 F Also, the metadata does not include the excitation (amplitude and offset). I would check the beta release of newer versions, but there doesn't seem to be a beta for the Mac OS X, just Windows and Linux.
  7. There is a bug in the export of data from the impedance analyzer from Waveforms (specifically from Waveforms 3.8.2 using the Analog Discovery 2, but I have seen it with earlier releases of Waveforms 3 also). The problem is that the frequencies are reported as if they were from a linear sweep, even though a logarithmic frequency sweep was done: #Date Time: 2018-07-01 16:50:47.258 #Trace: Trace #Start: 100 Hz #Stop: 1e+06 Hz #Steps: 101 #Resistor: 10000 Ω #Average: 10 #ProbeCapacitance: 1.04e+06 Ω #ProbeResistance: 4.3e-11 F #Compensation: Open Short #Wavegen: Wavegen1 #Amplification: 1
  8. There appears to be a mistake in the WaveForms SDK Reference Manual supplied with the SDK. The document says: But the function actually requires the idxChannel AND idxNode, like this: I'm running the following code segment to get the different node options: num_channels = c_int() dwf.FDwfAnalogIOChannelCount(hdwf, byref(num_channels)) print(num_channels.value, "channels") for i in range(0, num_channels.value): print("Channel", i) channel_name = create_string_buffer(32) channel_label = create_string_buffer(16) dwf.FDwfAnalogIOChannelName(hdwf, c_int(i),
  9. When I save a workspace and restore it in Waveforms 3.6.8, the measurement list in the Scope interface keeps the peak-to-peak, DC RMS, … setting, but loses the channel information, so that the measurement list has to be cleared and re-created each time I load the workspace. Note: I had renamed the channels (so they had names like Voltage with label "V" and Current with label "I", instead of C1 and M1).
  10. In Waveforms 2015 3.6.8 on a Mac OS 10.11.6 with an Analog Discovery 2, I am not able to get the SPI sensor scripts to work. I'm having no trouble with Master or Custom scripts, but with the Sensor scripts the ReadWrite() commands always return an array of zeros, even if I'm not in Debug mode. (I tried starting from a fresh run of Waveforms, to make sure that the debug setting was not just being excessively sticky.) Can anyone else duplicate this behavior? Or is it just me? Incidentally, the documentation for the protocol instrument and the scripts is woefully inadequate—I had to
  11. I'm running waveforms 2015 3.5.4 and got a bug/request. When changing the timebase, the position should not change. When I use the scroll the wheel or the timebase pop-up the actual position of the trigger point moves around in the scope graph window, this is very frustrating. Once you set the trigger x position, it should never move. Thanks.
  12. hello guys, I am new to this forum . I am implementing md5 in Verilog. I am almost done with it somehow but still stuck half in a way.. can someone can help me in finding the bug in the rtl. I have referred pancham md5 source code for it and have modified a little bit as per my application. here, are the two attached files kindly help me in solving these issues. have been trying since long. I have to calculate the hash value of about 512 bytes but first of all trying from smaller input values md5.txt1.txt pancham_round.txt
  13. I think that I have tickled a bug in Waveforms 2015 (version 3.5.4 and at least one earlier version) when outputting Network data files. The Network tool allows you to sweep the frequency down instead of up, which is very handy when using very low frequencies, as the auto setup does an extra two runs at the first frequency, which can take a lot of extra time if the low frequency is 100mHz. Everything works great, until you save the data. The frequencies in the file are not properly paired with the other columns—it looks like the frequencies are being regenerated sweeping upward, even th
  14. I have installed Adept 2 and Waveforms 3.3.7 from the Digilent website. I can open the Waveforms software and use it in demo mode with no issues, but the moment I plug in my Analog Discovery 2, the application crashes. The .crash file is too big to upload directly, so I have uploaded it here: https://dl.dropboxusercontent.com/u/971295/_usr_lib_digilent_waveforms_waveforms.1000.crash This issue is entirely deterministic with my setup, so please let me know if any additional information would help.