Search the Community

Showing results for tags 'arduinouno'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments and the WaveForms software
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Hi everybody, I have an RFID module which can be controlled through an RS232 communication. I have tested it with a rs-232 connection with a PC and with an also with an usb-serial converter. I can connect with the RFID module an receive its data through a terminal emulator such as Teraterm, PuTTY, etc. The data are simply ASCII strings of codes. The module can also be configured by sending some ASCII commands, this is also tested. Now I want to do the same with a microcontroller (Arduino, Lopy, etc.), i.e., the microcontroller would act as the PC, getting data from the RFID reader. I have acquired a Pmod rs232. The needed connection with the RFID module is shown in the attached image. The RFID module comes with a rs232 wire with the connections made. I connected the d9-female side connector to the Pmod rs232 through a female-male gender like this one. My understanding is that the RFID module is a DTE since RXD and TXD are crossed as can be seen from the image. I have connected the Pmod rs232 to Arduino but I am not able to see anything. So the scheme is: Arduino UNO serial connection --> Pmod rs232 --> rs232 wire --> RFID module. The connection is 9600 8N1. I tried some code such as "if some character is received activate internal LED", or getting the data through a configured software UART and sending data through the USB and see them in serial monitor. So far with no success. I have some questions: 1- My understanding is that this Pmod rs232 is a max232. Can be any problem if I am doing a DTE-DCE connection or DTE-DTE? I seem to understand I just would have to connect the TTL pins accordingly. Pins 1 and 2 are unconnected. 2- How can I test the Pmod rs232 is working? This is connected to arduino 1, on the ttl side pin 6 is connected to 5V, pin 5 to gnd, and 4 and 3 to RX and TX respectively. 3- Is there any other way to check where the problem is? Any advice will be very welcome, I am stuck with this. Thanks in advance. PS: Long time ago I designed a PCB based on a PIC and a max232 and I could succesfully communicate with the RFID module.
  2. I am facing problem in interfacing the PMODIA AD5933 board with ARDUINO UNO. I am using the attached Library and Program to find out the impedence, phase and frequency measurement. It is running if the start frequency is set to 1000 Hz in the program. The problem is I'm calibrating with RFB = 100K and Rcal = 100K but the impedance is coming in negative value. PMODIA AD5933 Board Connection with ArduinoUNO Board is : SDA--> A4 SCL--> A5 VCC--> 3.3V/5V GND-->GND ad5933-test.ino arduino-ad5933-master.zip