Search the Community

Showing results for tags 'arduino uno'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 6 results

  1. SufSam

    Pmod wifi

    Hi, I have two problems regarding wifi 1- I am trying to connect the pmod wifi to an arduino uno. I looked for a library, the best I could found is the WiShield https://github.com/airsoftsoldrecn9/WiShield . Clearly, this library is for the WiShield https://www.elechouse.com/elechouse/index.php?main_page=product_info&cPath=90_186&products_id=2165 but I thought because they use the same wifi chip as the pmod wifi this could work. However, after I manage to compile the library (I attached the working library after some minor modification in order to for it to compile) and after I connected the pmod wifi to the SPI of the arduino uno nothing seems to work. I tried to debug and I noticed that the code stuck in initialization stage, specifically in the file g2100.cpp line 144 (do-while loop). Could any one be kind enough to help or, if there is a working library for pmod wifi, that would be great. 2- I have the chipkit wi-fire rev C,I tried the example WifiTcpEchoServer which is working just fine. However, I need to make the kit act as TcpClient, so I tried the example WifiTCPEchoClient, however it does not work. The problem is that the kit does connect to the router, however, it does not connect to another tcp server on the PC. I tested to see if that is a problem with firewall, but it is not. I tired to debug and I noticed that the code stops at deIPcK.tcpConnect function. I appreciate any help. Thanks WiShield3.zip
  2. Hello, I'm trying to get a PMOD MTDS working with an Arduino Uno. I've read over the MTDS quick start guide and many other reference guides but cant seem to which pins to connect to/from the pmod to/from Arduino. Does it matter if I use digital vs analog pins? And how do I define those pins to ensure that the pins are receiving/ sending the correct information? Thanks in advance!
  3. Hi, I have purchased the Multi-Touch Display Shield, see link below for actual model. https://reference.digilentinc.com/reference/add-ons/mtdshield/start I have downloaded the Arduino IDE folder, installed the mtds & MyDisp libraries and followed the QuickStart.txt. When I open an example from either of those libraries and attempt to compile, it fails and lists loads of errors (Please see .txt file attached where I have copied error messages). I have my Arduino Uno selected and the libraries installed, there are errors in the followings directories: \Arduino\libraries\MyDisp\Examples\MyDispDemo\MyDispDemo1\MyDispDemo1.pde \Arduino\libraries\mtds\MtdsCore.cpp \Arduino\libraries\mtds\MtdsFs.cpp \Arduino\libraries\mtds\MtdsHal.cpp Does anyone know what is causing this, I have tried both Arduino 1.6.9 & 1.8.5 but it shows the same errors. Any help would be appreciated. Thanks, Evan Error compiling for board ArduinoGenuino Uno - Error Message.txt
  4. Hello Digilent community, I'm running an analog shield on an arduino uno (well, actually an Ruggeduino SE, but I understand they would operate the same here). Arduino 1.8.2 I'm reading from two sensors and reporting data to the terminal.The board is attached to and powered by usb (which reads ~4.75 V): The sensors are powered form the Analog shields +5/-5 V rails. 1) A thermistor that is dropping over a 10K resistor on analog channel 0. The analog shield reports the thermistor reading ~48150 A/D counts when it reads ~2380 mV with the multi meter. 2) an ion selective electrode another sensor that outputs -150 to +150 mV on analog channel 1. The sensor reads ~33070 counts and 55 mV with the multimeter I would like to know the transfer equation to convert the A/D count so that I can compare the analog shield reading to my multimeter. The sensors have been characterized in the voltage domain so I would like to convert the A/D counts to volts so that I can convert the sensor readings to engineering units (celsius, etc).This is a newb question, yes - I don't have any experience with bipolar sensors and A/D converters. Typically the transfer function for A/D to volts is something like this: Equation 1 (from googling around): Volts = ((A/D reading / (Nbits-1))* Vfullscale) - Vfullscale/2 For this system I've gathered the following info from the datasheets and docs: Nbits -1= 2^16 -1 = 65535, Vfullscale = 10V (5V to -5V), Are these values correct? Should I change them to the bus voltage that is measured (for example, change 5V to 4.75V when plugged into USB)? Plugging these values in for the thermistor reading I get: 2347 mV, an error of ~1.5%, not bad. Plugging these values in for the ion selective electrode reading I get: 46.2 mV, an error of ~16%. Do these error magnitudes seem acceptable to you? I'll likely re-characterize sensors with this platform as it will deployed rather than relying on the previous sensor characterizations done with a multimeter. I'd like to know if this is this the correct approach to convert A/D counts, and if so, suggest it be added to the example code or documentation to help others. If not, please let me know how and where I'm in error. Here is the code: //include libraries #include <analogShield.h> //Include to use analog shield. #include <SPI.h> //required for ChipKIT but does not affect Arduino\ //Defines // which analog pin to connect #define THERMISTORPIN 0 #define ISEPIN 3 // full scale voltage (5V- -5V) #define VFS 10.0 //loop delay time in ms #define DELAYTIME 1000 //16 bits (0 to 65535) #define NBITS 65535.0 void setup() { Serial.begin(9600); } void loop() { // read data from A/D double ISE_counts = analog.read(ISEPIN); double therm_counts = analog.read(THERMISTORPIN); //Convert A/D counts to volts double ISE_volts = ((ISE_counts / NBITS) * VFS) - VFS / 2; double therm_volts = ((therm_counts / NBITS) * VFS) - VFS / 2; //print data to the terminal Serial.print("Average temperature voltage: "); Serial.println(therm_volts); Serial.print("Average ISE voltage: "); Serial.println(ISE_volts); delay(DELAYTIME); } Thanks in advance,
  5. SUSHMA MANTAGANI

    ETHERNET SHIELD

    Hello, I'm glad that this forum conentrates on technical problem solving . PROJECT: To control the stepper motor (x and y axis) through a website ,using ethernet shield and arduino uno. Ps :Esp8266 cannot be used. I'm following the attached code to which will take the Ip adress(line 29) and server address(line 26) and connect to the following website created by php and my sql(line 61). Created by Tom Igoe, based on work by Adrian McEwen. ISSUES FACED: The code must connect first and then it directs us to the website provided.But in my case it is not connecting . I vant attach the serial monitor status image(more than 1.95MB) What have i done ? I have connected the ethernet shield to router wire of college (having two step authentication , with password and all***) .The ethernet shield I have got doesnt have a mac (meadia access control) address on it (i verified with the shopkeeper , even he told it wasnt provided to him either ).. When surfed on internet , i found out that only new ethernet shields have mac address , so i connected the ethernet to my PC and obtained the physical address ( added 0X in front of it to make it hexadecimal ) and added it in the code. The website added in the code is php based , but I want to add a html with 4 buttons ,indicating motor1 - clockwise ,anticlockwise and motor2 - clockwise , anticlockwise .acn i add this html ( starting from <html to <!html> in the code itself?and get that page as sson as ethernet is connected? After connecting , the website must open and based on our inputs of the button we press ,stepper motor code must be cascaded in the ethernet code , so it works well. (code regarding stepper motor and html isnt written yet). Do go through the message , I will send anymore supporting pics or will tell you about it ,so that you can unserstand the scenario and debug it right. Hope you see this message soon and help me right, Thank you SUSHMA MANTAGANI ***Is that ethernet doesnt take a router with 2 step verification or the code can be modified so that use rid and password can be added , so that it will be connected ? arduinomysql.ino.ino
  6. I am working on an Arduino Uno R3 which i had bought from http://www.w11stop.com/ard-uino . I wanted to have the ability of controlling the Arduino wirelessly, like stopping the Arduino without having to pull the power-plug every time. Is it possible?