Search the Community

Showing results for tags 'CONFIG_VOLTAGE'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments and the WaveForms software
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi everyone, I have a Nexys4 board and I am trying to generate a simple program in VHDL using Vivado 2014.4 Webpack. When I get to the Generate Bitstream phase I get the following warning: ----------------------------- WARNING: [Drc 23-20] Rule violation (CFGBVS-1) Missing CFGBVS and CONFIG_VOLTAGE Design Properties - Neither the CFGBVS nor CONFIG_VOLTAGE voltage property is set in the current_design. Configuration bank voltage select (CFGBVS) must be set to VCCO or GND, and CONFIG_VOLTAGE must be set to the correct configuration voltage, in order to determine the I/O voltage support for the pins in bank 0. It is suggested to specify these either using the 'Edit Device Properties' function in the GUI or directly in the XDC file using the following syntax: set_property CFGBVS value1 [current_design] #where value1 is either VCCO or GND set_property CONFIG_VOLTAGE value2 [current_design] #where value2 is the voltage provided to configuration bank 0 ----------------------- The program apparently works OK even though there is this warning. I am using the constraints file provided by DIGILENT: http://digilentinc.com/Products/Detail.cfm?NavPath=2,400,1184&Prod=NEXYS4 where I have uncommented the clock signal, the 7 segment displays and the first switch. I have tried to solve this but I am new to FPGAs and there is an overwhelming amount of documentation. It would be great if someone could help me. I don't want to change anything and risk damage to the board. I see that the example project provided by Digilent also has the same warnings. Thanks in advance Andres