Search the Community

Showing results for tags 'Audio Codec'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Calendars

  • Community Calendar

Found 2 results

  1. Using Zybo Audio Codec W/base Design

    Hi all, I'm trying to get something working with the audio codec on the Zybo board. In the end, I want to sample an electronic musical instrument, do some signal processing, and output the processed signal, but for now I'm trying to get the demo from the base design working. I can get the demo to work using the supplied bit stream by creating an SDK project with the bitstream provided in the project files. If I open the PL project in a newer version of Vivado (2014.3), upgrade the IP cores, generate a bitstream, and run the demo from the SDK as before, the program hangs and doesn't print anything to the terminal. I've narrowed down where the program hangs using print statements to when the audio codec is being initialized. In particular, it seems that the code has an issue with the "Xil_Out32()" around line number 146 of the audio_demo.c file. To me this likely means that there is an issue with the programmable logic, so perhaps when I upgraded the IP cores for the new version of VIvado? I've also tried deleting the generic IP cores in the block design and running the connection automation, but with the same results. I am using an external supply to power the board with 5V and a max of 1A, so that shouldn't be an issue. I'm curious if anybody else has tackled something like this and/or updated the Zybo base design for newer versions of Vivado. -J
  2. Linux Driver for Audio Codec on ZYBO

    Hi, I am trying to write a linux device driver for a project which uses audio codec. I am using the ip axi_i2s_adi codec for the project on ZYBO . I see that the functions in the demo file are written for Vivado. I mean the functions uses XIlinx header files and functions. I think I cannot use those to build device driver. If somebody has written device driver by themselves or know where i can find, please share the details with me. Thank You, Ramu