Search the Community

Showing results for tags 'jtag'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments and the WaveForms software
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 95 results

  1. Hello, I'm planning on buying the product "Cmod C2: Breadboardable CoolRunner-II CPLD Module" to make some prototypes of future designs. I saw that, in order to program its CPLD (XC2C64A), I need to buy a USB to JTAG cable. Is the Diligent's JTAG-HS1 programming cable compatible with that CPLD and board?. I will be using the last version of ISE on Windows 10, will it be a problem?. If it helps answering, this are the links of the Digilent's store of those products: Breadboardable CoolRunner-II: https://store.digilentinc.com/cmod-c2-breadboardable-coolrunner-ii-cpld-module/ JTAG-HS1 programming cable: https://store.digilentinc.com/jtag-hs1-programming-cable-limited-time/
  2. I just received my JTAG-HS3 Rev A programming cable and if I plug it into my windows 10 machine I don't see anything unique showing up in the device manager. I know something is popping on and off because I can hear the device attached and device detached sounds from windows. So what should it show up as?
  3. Hello, I am using Arty-Z7-10 board with 3 Pmods (NAV, GPS and RTCC), while there are only 2 JTAG ports available on the board. So, I decided to buy one of these 2*6-pin JTAG splitter cables and divide one of my JTAG ports between PmodGPS and PmodRTCC (since both of them need only one row of JTAG). Now, I am trying to make a block design and connect both of them to one JTAG, but it does not seem to be feasible. When I connect the first Pmod to the JTAG port, it occupies the whole port and it does not allow me to add another Pmod to it. Is this something I have to do in Verilog, and modify my XDC file? or is there an easier way to do it by just dragging and dropping the IPs in the block design? Best, Mahdi
  4. Hi FPGA gurus ! I am facing trouble while trying to attach my Atlys USB JTAG device to a Centos 6 virtualbox VM. I recently had no choice but to upgrade my computer from Windows 7 to Windows 10. As a Windows 10 version of ISE 14.7 was available, I decided I could do the upgrade before realizing that ISE 14.7 for Windows 10 was indeed ISE 14.7 for Linux running a VirtualBox... Nevermind. The problem is that it seems I can't attach Digilent USB JTAG to the VirtualBox. Here is my configuration : Windows 10 Pro VirtualBox 5.2.8 (I upgraded it so that I could install Extensions to enable USB 2 and USB 3 support) Adept2 is installed on Windows 10 and works fine, Atlys board is recognized and I can run the test application OK. Now, here is my problem : Let's turn on the computer first and do a fresh test ! Atlys Board is attached to USB ports (JTAG and UART) but is turned off. VirtualBox USB configuration is configured as shown in USB_parameters.jpg Now, let's turn VM on, Atlys board still off. The attachable USB device list in VB is shown in USB_devices_atlys_off.jpg As you can see, neither JTAG nor UART devices are listed, which is expected as Atlys board is off. Now, let's turn the Atlys board on and see if the listing has changed... It has ! as shown in USB_devices_atlys_on_1.jpg Also, you can see in Device_mgr.jpg that Windows has no driver problem with JTAG and UART devices. You may notice UART device is automatically attached. Looking at /dev/tty* shows that the UART device is now available through /dev/ttyACM0 as shown in TTY_devices.jpg Let's have a look at the JTAG device status (USB_devices_atlys_on_2.jpg), it reads "captured", whatever that means ... Now, let's try attaching it... It raises an error with message shown in Digilent_USB_JTAG_attachment_error.jpg "USB device is busy with a previous request" :/ This is sad ... Of course, no other device appears in /dev/tty* Greping dmesg for FTDI pattern returns Nothing. Only UART USB devices appears in dmesg log... I've tried the same test with USB 3 (xHCI) configuration selected. Do any of you have an idea on how I could attach the USB Digilent JTAG device to my Centos 6 VirtualBox machine ? Any help will be highly appreciated. Thanx a lot. Cheers
  5. sdm

    FMC-CE Breaks JTAG Chain

    I've got the FMC-CE board plugged into a ZC706, and when I try to load open the Hardware Manager in Vivado, it finds my HW target, but there are no devices found. After a little digging I found that there is an FMC design rule that if you don't use the JTAG chain you need to tie the FMC TDI pin to the TDO pin. Looking at the schematic, this isn't done on the FMC-CE board. Both of these FMC pins (D30, D31) are disconnected. What's the best way to work around this to enable JTAG debug when this board is installed?
  6. The attached image is probably the easiest way to ask this question .. We want to program 6 devices all at the same time using 6 copies of a USB-JTAG device (as opposed to having once large JTAG chain). It looks like Impact / Vivado does not natively support this (it sees multiple dongles but only deal with them one at a time). Can we script something to load a BIT file on all 6 simultaneously? We currently have the XUP USB-JTAG Programming Cable but would switch to another one if this one can't do it. Thanks!
  7. Theo

    Damaged HS2 cable?

    I wonder if I have encountered the same issue as Mojy with my Digilent HS2 JTAG cable. I raise the question again because it looks like the question was answered, but by a private communication. I'm running Red Had Linux 7.4. I've installed the Adept Runtime and Utilities packages. Previously, running djtgcfg enum had listed the HS2 device. Now, it does not. However, the lsusb utility recognizes the device as Future Technology Devices International, Ltd FT232H Single HS USB-UART/FIFO IC I see that this is the bridge chip inside the HS2. I think Mojy's original assessment of lost EEPROM may be correct. Can you help? Thanks, Theo
  8. We have recently purchased a JTAG-SMT2 board in substitution of a JTAG-HS2 cable, in order to program a Microzed board with Xilinx Vivado. The same Windows machine that was working with JTAG-HS2 now recognizes the new device JTAG-SMT2 as "USB Serial Converter". We have tried some solutions in other forums, as using FTDIconfig, with no success. What is remarkable is that, when plugging the device, Windows 1st finds a "Digilent USB device", but then automatically installs a driver and it is converted into "USB Serial Converter".
  9. I have a system where I'm using 2 HS2 cables. One is used for SPI control and the other for Jtag. For my SPI interface, I have written a DLL using the ADEPT2 SDK, that allows me to specify the serial number of teh device to connect for SPI. Unfortunately both devices enumerate as device name "jtagHs2" and If I start my Xilinx Viivado Hardware manager before my SPI interface, the Vivado is taking over the device I want to use for SPI. If I start my spi interface first then vivado correctly picks up the HS2 I want to use for JTAG. Is there a way to prevent this, for example can I change the name "jtagHS2" in my SPI interface eeprom? Thanks, Patrick
  10. I'm using the Nexys Video board and I'd like to use the FIFO capability of the FTDI chip (IC13 connected to J12) to get data from the FPGA quickly and easily while keeping the JTAG lines high-impedance. I would like to use the FT2232H FIFO port while using our own JTAG (J17). The JTAG lines on that chip are high impedance until the USB cable is plugged in and I'd like to keep them high impedance while using the USB port. If you don't know, can you send me the schematic page for IC13/J12?
  11. Hello, I bought Arty-A7 development board and I will use it for Risc5. How can I connect a host pc to this board for using openocd? This board has 'FT2232HQ' and does it mean that I can use USB port for JTAG and UART at the same time? (Or should I buy any other cables for using openocd?) Thanks,
  12. Hi, Recently, the JTAG SMT1 on our Xilinx VC709 FPGA board is physically broken (and we are sure that the only broken part on this board is JTAG). However, it seems that JTAG SMT1 has retired and the only available one on your website is JTAG SMT2. So I want to know if we can replace the broken SMT1 with a new SMT2. In another word, is SMT2 compatible to our board? Thanks.
  13. smarano

    eFuse Programming

    Hi I'm tring to program my cmod a7 35T Digilent board with an encrypted bitstream. I read that to do this i need to program the eFuse register with a key.nky file, but when i try to do this i found a problem. This board don't have a jtag connector but it can be programmed via usb. When i try to program efuse a found a problem "cannot program efuse register with this cable". Anyone can tell me if there is another way to program efuse or if this board can't support encryption bitstream? regards Stefano
  14. Hello, everyone. We are planning to access JTAG by attaching a pin header to J8 of Arty board in order to confirm efuse access. (I dont use USB-JTAG.) Which signal corresponds to each of the six through holes of J8? I check the reference manual and circuit diagram, but there is no clear description. From the relationship with the D1 diode on the circuit diagram, I guess the following order. Is it correct? 1. TMS_JTAG (suquare, 1 pin mark?) 2. TDI_JTAG (circle) 3. TDO_JTAG (circle) 4.TCK_JTAG (circle) 5. GND (circle) 6. VCC 3 V 3 (circle) best regards, ryo
  15. gm_

    JTAG HS2 completely silent

    Hi all, I have just tried my JTAG HS2 on 4 PC with windows and linux, but the device is not recognized by any of them. I also tried to change the usb cable to no avail. Any idea to what else I could do before sending it back? Thanks!
  16. Dear all, I would like to buy JTAG HS2, but I have the followings doubts: 1. is it recognised by Fedora? 2. does it support debugging? 3. does it work with urJTAG? 4. is it compatible with openOCD? Thanks! gm
  17. Hi, I am trying to rebuild the arty z7 petalinux BSP as per the instructions given by them here https://github.com/Digilent/petalinux-bsps/wiki/Quick-Start-Guide-for-Arty-Z7. But when I try the command $ petalinux-boot --jtag --prebuilt 3, I get an error saying [[email protected] Digilent-Arty-Z7-Linux-BD-v2016.2]$ petalinux-boot --jtag --prebuilt 3 ERROR: No subsystem configuration file can be find in the project. sh: lsb_release: command not found webtalk failed:Invalid tool in the statistics file:petalinux-yocto! webtalk failed:Failed to get PetaLinux usage statistics! Anybody knows what the issue is? Karthik
  18. Jennifer

    Impact 13.2

    I am running Impact 13.2 (Windows 64-bit). I have installed the Digilent plugins. When I try to initialize the JTAG chain, I get an error saying that the selected cable is being used by another application. There are no other cables attached to the laptop.
  19. Hello I'm using Digilent JTAG-HS3 Programming Cable with a Zynq 7000 based board. With HS3, I'm able to program the PL of the Zynq using Vivado 2016.4. In my application, I need to have an extension cable connection the Zynq to the HS3; this extension cable is about 1m long. In case I set the reference voltage on the base board to 2.5V, I'm able to connect to the Zynq, program it and flash the QSPI memory. On the other hand, if I change the reference voltage on the base board to 3.3V, I'm not able to detect the Zynq at all. In Vivado, I obtain the error message: ERROR: [Labtools 27-2269] No devices detected on target localhost:3121/xilinx_tcf/Digilent/210299A1F0C9. Are there any specific requirements to make the extension cable work with HS3 and Zynq using 3.3 reference voltage?
  20. Hi - I just tried to install the XUP USB-JTAG Programming Cable from diligent. I also have a Diligent Programming Cable. Centos can see both cables (see below) Vivado can see the Diligent programming cable but not the Xilinx one. Given the physical constraints of the installation only the Xilinx one will work. Are there any specific instructions to get the Xilinx cable going? $lsusb | grep "Xilinx/|Future" Bus 002 Device 003: ID 03fd:000d Xilinx, Inc. Bus 001 Device 006: ID 0403:6014 Future Technology Devices International, Ltd FT232H Single HS USB-UART/FIFO IC
  21. I have a device that loses all its firmware when the battery dies and would like to be able to copy the firmware from a good one so I can reload the firmware to ones that have died to get them running again. I know the chip inside is a Dallas DS5250FP-825 and the connector the device uses to communicate is a 6 pin JTAG. What tools will I need to do this? Sorry I'm new to all this so any info or a point in the right direction will be helpful and I'll try to answer any question I can.
  22. I'm trying to use the Adept Utility to program a 3A-DSP1800 device with the HS1 JTAG cable. I have no issues with a regular 3A device. With the 3A-DSP1800 device the utility correctly reads the ID code but displays "UNKNOWN DEVICE" where it should display the correct device. My memory is a bit fuzzy on this, but I seem to recall that the utility needs to have specific devices listed in some configuration file for the cable. I have no idea where to look. I was able to use IMPACT to program the device using the HS1 so I know that the issue is software related. Any help would be appreciated as it sure is nice using the Adept Utility in windows; and I'm not particularly fond of Impact. Also, the Adept Utility and Impact don't get along even when the Adept Utility is connected to a different device ( in my case it is ).
  23. Hi, It gave such errors when I tried to download data from CentOS virtual machine: .................[DIGILENT] transmit (DpcPutTmsTdiBits): xmit failed of 16 bits [DIGILENT] DPC error returned 3076 is unknown. [DIGILENT] transmit (DpcPutTmsTdiBits): xmit failed of 8 bits [DIGILENT] DPC error returned 3076 is unknown. [DIGILENT] transmit (DpcPutTmsTdiBits): xmit failed of 8 bits [DIGILENT] DPC error returned 3076 is unknown. [DIGILENT] transmit (DpcPutTmsTdiBits): xmit failed of 8 bits [DIGILENT] DPC error returned 3076 is unknown. [DIGILENT] transmit (DpcPutTmsTdiBits): xmit failed of 8 bits [DIGILENT] DPC error returned 3076 is unknown. And on native Linux machine it works just fine. Any idea how to fix this issue? Thanks, Dexian
  24. Hi everyone, I have started using the Nexys Video board and have a question about DPTI before starting: I understand that when channel A is used in synchronous FT245 mode in the FT2232 chip that channel B is switched off. Is that correct? That would mean I cannout use synchronous DPTI in parallel with Vivado debugging, right? One alternative is using asynchronous mode apparently, but I am also wondering if I could connect my debug cable to the unequipped JTAG port instead? Anyone tried that setup? Cheers, Stefan
  25. Hi Digilent Users, In 2006, I bought one of your development PCBs which is marked "Xilinx XC2-XL" and has one XC9572XLVQ44C, one XC2C256TQ144C, and a very nice prototyping area. The associated paperwork gives the part number as "DO-CPLD-DK" which matches the Obsolete Digikey P/N 122-1512-ND. The good news - When I powered up the board with two AA batteries, the LEDs responded to the pushbutton. The bad news - The kit that I have has a Parallel Port - JTAG cable. The question - Can I use JTAG-USB PROGRAMMING CABLE, Digikey P/N 1286-1052-ND, Digilent P/N 250-003 to program my PCB? Thanks, Dave Crafts