Search the Community

Showing results for tags 'ftdi'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 16 results

  1. Hi, We have custom designed control board for our business needs which uses Atrix-7 FPGA. The control board design contain FTDI chip along with 93AA56BT EEPROM chip. we want to use this setup to access JTAG and flash/debug FPGA through viviado. We used Arty boards for initial FPGA development. The question is how can we make our custom board FTDI chip working the same as Arty boards. Do we need licensed EEPROM contents if so then how can we get it and how to program it. Any help would be appreciated. Regards, Ali
  2. I am using an FT232 breakout board to control a rotary sensor through Python 2.7 If I plug in the AD2 first, my python code fails due to "no device found". If I plug in the FT232 first, and establish the connection with Python, everything works OK. How can I track down the cause and resolve it? The errors listed follow: C:\Python27\lib\site-packages\adafruit_gpio-1.0.3-py2.7.egg\Adafruit_GPIO\FT232H.pyc in __init__(self, vid, pid, serial) 148 if serial is None: 149 # Open USB connection for specified VID and PID if no serial is specified. --> 150 self._check(ftdi.usb_open, vid, pid) 151 else: 152 # Open USB connection for VID, PID, serial. C:\Python27\lib\site-packages\adafruit_gpio-1.0.3-py2.7.egg\Adafruit_GPIO\FT232H.pyc in _check(self, command, *args) 202 logger.debug('Called ftdi_{0} and got response {1}.'.format(command.__name__, ret)) 203 if ret != 0: --> 204 raise RuntimeError('ftdi_{0} failed with error {1}: {2}'.format(command.__name__, ret, ftdi.get_error_string(self._ctx))) 205 206 def _poll_read(self, expected, timeout_s=5.0): Here is my code: # Python program to use FT232H from a USB port to read and program the MA302 encoder import Adafruit_GPIO.FT232H as FT232H import binascii import sys from time import sleep # Temporarily disable FTDI serial drivers. FT232H.use_FT232H() # Find the first FT232H device. ft232h = FT232H.FT232H() q=spi.transfer([0x82, 0xbf]) #write register 2 with 0xdf sleep(.020) print "q=";q
  3. Hi, I'm using an CMOD A7 board that use an FT2232HQ USB-UART bridge. I have installed the driver from FTDI Chip Community and all work perfectly but sometimes there is an issue. I have about 10 board, if i connect one to pc and try to communicate with it, all work, sometimes if i disconnet this board and connect another the Pc recognized it but i can't communicate with it. I don't know why but to bypass this issue i need to open device manager and uninstall the USB Composite Device Driver and install it again and all work correctly. This is an issue because i won't to do this procedure each time that the problem occurs. Anyone can help me? Regards Stefano
  4. Recently acquired two of those Digital Discoveries to use on macOS 10.12.6... It works nicely, but only if you don't have any other FTDI device connected as well on the Mac... Either it doesn't detect the device anymore, says that the discovery is busy, or crashes for example my self-built Mac or tells me "DptiEnableEx failed ERC: 0x3, Device opening after programming failed" Haven't tested with two discoveries at once as the other one is in the office... This is really a show stopper as we have many devices for hardware debugging where a USB serial adapter must be used.
  5. yassinema2018

    UART FTDI chip

    i tested a uart verilog design working great on the zybo at 9600 bits/s, i can communicante with externel MCU's, now i want to send and recieve some data from my laptop. for that i want to use the onboard ftdi chip on the zybo, is it possible to access to MIO pins and write uart data the chip inputs ? thank you
  6. Is there anyone that has a direct link to download just the USB drivers for the Analog Discovery II (not part of Waveforms 2015)? We are having driver issues on Windows 10. We've tried every other solution that we could find on these forums. (Manually pointing to the drivers, rebooting, reinstalling waveforms including the Adept Runtime, etc.) We are looking for JUST the drivers that someone from tech support can send us while trying to fix this problem.
  7. I'm writing a USB to JTAG programmer using Adept SDK APIs. Does anyone know if there is a way to set the FT232H chip IO drive strength which appears to have (4ma, 8ma, 12ma, or 16ma) options available?
  8. Within the schematics of the NEXYS 4 and NEXYS VIDEO boards I couldn't find the part with the Micro-USB JTAG bridge. The part with the FT2232HQ chip is left out in both schematics. Is there a reason for neglecting those parts? Could I find the schematics elsewhere? I'm especially interested in the differences between a combined JTAG and UART Micro-USB solution (as seen on NEXYS 4) and two separate solutions Micro-USB JTAG (1) and Micro-USB UART (2) (as seen on NEXYS VIDEO).
  9. Hello, I have an issue similar to this one, but not related to USB hubs: Basically, after I installed Waveforms and the USB driver, I can no longer connect to the serial USB device that I am trying to debug! I am forced to kextunload and then kextload again to make them connect: ➜ ~ ls /dev/tty.* /dev/tty.Bluetooth-Incoming-Port /dev/tty.lpss-serial1 /dev/tty.lpss-serial2 ➜ ~ sudo kextunload /Library/Extensions/DigilentFtdiDriver.kext ➜ ~ ls /dev/tty.* /dev/tty.Bluetooth-Incoming-Port /dev/tty.lpss-serial1 /dev/tty.lpss-serial2 /dev/tty.usbserial-1412A /dev/tty.usbserial-1412B ➜ ~ sudo kextload /Library/Extensions/DigilentFtdiDriver.kext ➜ ~ ls /dev/tty.* /dev/tty.Bluetooth-Incoming-Port /dev/tty.lpss-serial1 /dev/tty.lpss-serial2 /dev/tty.usbserial-1412A /dev/tty.usbserial-1412B Is there any way to fix this? The other devices are using the generic FTDI VCP driver. My computer is the latest MacBook Pro 15".
  10. I'm using the Nexys Video board and I'd like to use the FIFO capability of the FTDI chip (IC13 connected to J12) to get data from the FPGA quickly and easily while keeping the JTAG lines high-impedance. I would like to use the FT2232H FIFO port while using our own JTAG (J17). The JTAG lines on that chip are high impedance until the USB cable is plugged in and I'd like to keep them high impedance while using the USB port. If you don't know, can you send me the schematic page for IC13/J12?
  11. Installed Waveform 2015 software as instructed and installed the driver also. Couldn't get the Analog Discovery 2 to get recognized until after I rebooted the system. But it is only recognized if I plug it directly into my machine. If I use a hub, It doesn't work. The problem is I have several Arduino boards that use FTDI chips also plugged into my system through hubs and they were all working just fine before I installed your provided driver. Now they also only function if they are plugged directly into the laptop. I can't operate that way, how do I uninstall the driver or keep your driver from breaking my other devices on the system. Even one of my hard drives that is connected through an Anker 3.0 HUB no longer connects unless directly connected. Another hard drive is still working through the hub. After restarting the mac several times, I got things to work by unplugging the actual powered hub. Unplugging from the computer wasn't enough, I needed to unplug power from the hub before things started to work again. We still need some sort of uninstall instructions. macOS Sierra 10.12.3 MacBook pro Mid 2012 16 Gig ram.
  12. Hi everybody, I have to communicate with the FPGA on my CMOD A7 board through the on board FTDI FT2232HQ chip. While on a PmodUSBUARD, for example, I can use the RTS/CTS hardware wires for the flow control, on the board datasheets it's written that I can only use the TX and RX hardware wires and that there are no RTS/CTS wires (fact confirmed by the board .xdc file too). How can I set reliable control flow for my high-speed communication (from 6Mbaud to 12Mbaud) ? Any advice? Thank you in advance, Antonio Daril Crispino
  13. Hi, I'm having a problem programming di EEPROM of the FT2232HQ on my Digilent CMOD A7 35T board with FT_PROG, I hope someone can help. I wanted to change the hardware and the drivers of the A port to UART and VCP respectivly. After that, noticing that I couldn't program the FPGA with Vivado anymore, I re-programmed the FTDI with FT_PROG to its initial state (port A with 245FIFO hardware and D2XX Direct drivers), but I'm still not able to program the FPGA with Vivado because it seems to not recognize any hardware target. It seems that the FTDI is not able to connect to and to control the JTAG circuitry anymore. I must say that first of all I also created a template of the EEPROM in order to have a stable state to which return in any case.Isn't there a way to program the FTDI to its inital (factory) state?
  14. Hi, Is it possible to program the JTAG-USB cable directly via the FTDI D2XX library, bypassing the Adept DJTG library? It seems to be possible to identify the device after a call to FT_SetVIDPID, but FT_OpenEx always seems to return FT_DEVICE_NOT_OPENED. Is another step needed first? Or is the source code for the Adept SDK libs available? Thanks, Jon
  15. Jensen

    Genesys 2 FT2232H

    Hello, I have a Digilentinc Genesys 2 board, my project needs to communicate between a PC and the FPGA. Because the data needs to travel at high speed I use the FT2232H-chip. I already can send data from the pc to the FPGA. But sending data from the FPGA to the PC isn't possible. My code(Verilog and Labview) works with a custom board with the same FT2232H-chip but not with the Genesys2. The problem is that the USB_TXEN doesn't go LOW. Is it possible that I need to set the USB-jumper(s) on another position? Does anybody know another source of this problem? With friendly regards, Jensen
  16. JTAG-USB-FTDI

    JTAG-USB Question

    I am interfacing between a USB IC (a FT2232H FTDI chip) and a EEPROM IC (a 93AA56BT). To make the FTDI chip recognizable by Xilinx tools I need licensed Digilent Serial Numbers. How can I get a licensed serial number file to enable a USB-JTAG FTDI interface? Are these licenses keyed specifically to your chips? How can I enable a JTAG-USB FTDI interface?