Search the Community

Showing results for tags 'Analogshield'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments
    • LabVIEW
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 9 results

  1. Hi all, I just got the AnlalogShield and its working like a charm. But I wonder if there is a chance to make this shield work on an Arduino Zero. It is supposed to work on an Arduino DUE, so I guess it should be just some software, library, modifications. Currently, when I connect a ZERO I cannot upload software to the ZERO because it says "chosen wrong processor type" Any ideas how to fix this? Thanks in advance, Ben
  2. Luc

    AnalogShield with Due

    Hi, I am trying to use the Analog Shield with the Arduino DUE. It compiles, but the board does do anything. With the analog shield plugged in the Due works as normal. all I do is include "#include <analogShield.h>" and upload to the board. then the board is dead like if it crashed on start up. when I remove the include line and recompile it works again. I am using the library found on this forum dated 6/6/2016. The board works well with my ChipKit uC32. Luc
  3. Hello everyone, and thanks in advance for reading this! On a current project, I’m working with a network of Arduino UNOs R3, each with an AnalogShield installed (to be precise, it’s 4 Arduinos+AnalogShields total, communicating over I2C). I immediately found a problem when I connected all their Vin ports together to a 12V power supply: they sourced too much current (my main power supply was reading more than 1 A!). So I quickly stopped that and tried connecting the 5V ports together to a 5V power supply. At first this was OK, but soon they started to source too much current again. I also tried powering one of them via USB and connecting all the 5V ports together… This works most of the time, but some times the 5V line’s voltage oscillates badly or they start sourcing too much current again... It's funny because sometimes things seem to work, and then stop working. I checked the health of all Arduinos and they are perfect. And I checked powering all Arduinos by themselves (no shields) both through their Vin and 5V ports, and that works with no issues... So it must be an issue with the AnalogShields... For the moment, as a temporary measure, I’m powering all of them independently through their USB ports, and connecting only their grounds together. But in my final configuration I’d like to be able to power all of them with a single power supply. Can anybody point to where the issue could be?
  4. I am working slowly on my project. I thought I might post what could be a useful DipTrace base layout for a shield to use with the Analog Shield on an Arduino Uno . It could even be useful to somebody making an unrelated shield for Uno by stripping out the P1, P2, and P3 headers on the left and adjusting the board outline. The component designations and pin numbers match those of the Analog Shield. My board may end up bigger than the Analog shield, but I have put a board outline into the file that matches the 2.1 by 3.1 inch dimensions of the Analog Shield. I think it is correct, but I have not had a board built. I made a copy of my in-progress layout, and stripped out the components. The Analog Shield uses Uno D2,D3, D5, D6 (P7-3,4,6,7) for its data to or from the Uno. As an aside, on my specific project, I have a Sainsmart 2x16 LCD Keypad-Shield that will go atop my custom shield. As far as I can tell, that uses Arduino signals D4,D5,D6,D7,D8,D9 and AD0. The Uno uses D13 for its LED, but could be shared in a pinch. That would seem to leave me with Uno D0, D1, D11, D12 to use for my own use by my shield. I expect to only need 1 or 2 Uno output port pins to my exclusive use. Any opinions as to which is/are most likely to be available, even if I upgrade to a different display shield in the future? Attached PDF is expanded scale. Bluish-gray is bottom silk. Green is top silk. Blue lines are ratlines for some of the grounds, and may be ignored. 1. I hope the DipTrace layout is useful to somebody. 2. Suggestions are encouraged. Analog_Shield_Base.dip img_ Analog_Shield_Base.pdf
  5. adralencar

    Analogshield and ChipKIT Wi-FIRE

    Does anyone know if AnalogShield will work on the new ChipKit Wi-FIRE (with few modifications) ? I look inside the library and I saw several " #ifdef __PIC32MX__ " However the new ChipKit WI-FIRE is " PIC32MZ ", MZ not MX. In other words, without any modification it will not work. However, if the chip is similar, as described in this forum, should be easy. Thanks
  6. mwingerson

    Andrews compiling code Old MPIDE

    From the album: Marshall's pics

    no errors
  7. mwingerson

    Andrews compiling code current MPIDE

    From the album: Marshall's pics

    no errors
  8. mwingerson

    analog shield with UNO32

    I am posting a support question on the forum so I can answer it here to help out others that may have a similar problem. " I downloaded the latest analogshield library from git hub. I'm trying to get the following code to compile in MPIDE: #include <analogShield.h> //Include to use analog shield. #include <SPI.h> //required for ChipKIT but does not affect Arduino #include <SoftwareSerial.h> // anndrews pins SoftwareSerial rs(4,7); //rx,tx // johns pins //SoftwareSerial rs(2,3); //rx,tx void setup() { pinMode(13, OUTPUT); digitalWrite(13, LOW); Serial.begin(115200); rs.begin(115200); Serial.println("Test"); } void loop() { } Compile errors are: In file included from C:mpidelibrariesSPI/SPI.h:16:0, from C:mpidelibrariesanalogShield/analogShield.h:54, from sketch_mar24a.cpp:1: C:MPIDEhardwarepic32corespic32/avr/pgmspace.h:4:2: error: #error ******** This sketch or library uses AVR-specific code that may not work with the chipKIT platform. See this forum for more information on porting code to chipKIT [www.chipkit.org/forum/viewforum.php?f=7] ******** In file included from C:mpidelibrariesanalogShield/analogShield.h:54:0, from sketch_mar24a.cpp:1: C:mpidelibrariesSPI/SPI.h: In static member function 'static byte SPIClass::transfer(byte)': C:mpidelibrariesSPI/SPI.h:56:3: error: 'SPDR' was not declared in this scope C:mpidelibrariesSPI/SPI.h:57:12: error: 'SPSR' was not declared in this scope C:mpidelibrariesSPI/SPI.h:57:19: error: 'SPIF' was not declared in this scope C:mpidelibrariesSPI/SPI.h: In static member function 'static void SPIClass::attachInterrupt()': C:mpidelibrariesSPI/SPI.h:63:3: error: 'SPCR' was not declared in this scope C:mpidelibrariesSPI/SPI.h:63:11: error: 'SPIE' was not declared in this scope C:mpidelibrariesSPI/SPI.h: In static member function 'static void SPIClass::detachInterrupt()': C:mpidelibrariesSPI/SPI.h:67:3: error: 'SPCR' was not declared in this scope C:mpidelibrariesSPI/SPI.h:67:12: error: 'SPIE' was not declared in this scope " The errors are because the tools are trying to compile the Arduino side of the library. I am curious why that is happening. I tried your code on my machine and did not have any compile issues so lets figure out what is going on. My setup: - Windows 7 - MPIDE 20140821 - latest version of the library here: https://github.com/mwingerson/analogShield - chipKIT UNO32 What is your setup? Thanks for contacting us on this issue.
  9. mwingerson

    Using Analog Shield with UNO32

    I am posting a support question to help help drive the AnalogShield knowledge base on the forum. "I purchased 2 Analog Shields and 2 Chipkit UNO32 boards and am trying to use them together. The web page for the Analog Shield is misleading and implies that the Analog Shield is compatible with the the Chipkit Uno32. However I cannot get the Analog Shield library to compile in MPIDE. There is a compile error that sates something like "the library contains AVR specific code and will not work on the the UNO32" or something like that. What's the deal? How do I get the Analog Shield to work with the Chipkit Uno32?" We are updating the product page to be easier to use but until then I can help you with support problem. Can you be more specific on what demo you are running? Also, the latest version of the library can be found here: https://github.com/mwingerson/analogShield