Ehud Eliav

Members
  • Content Count

    12
  • Joined

  • Last visited

  • Days Won

    1

Ehud Eliav last won the day on January 8

Ehud Eliav had the most liked content!

About Ehud Eliav

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi All Im using the Jtag SDK environment with the JTAG-HS2 probe, Wondering if you already have (or can recommand on somewon who already wrote) C code that support*** SVF commands (see link: http://www.jtagtest.com/pdf/svf_specification.pdf)? (Of course i can implement it by using the API functions - but it will save me some development time ) *** support means: C function for each SVF command like SDR,SIR... that receive a data/instruction as parameter SVF Command example: ---------------------------------------------------------------------------- SIR 8 TDI(00000055) ; RUNTEST 1000 TCK; SDR 18 TDI(00031234) TDO(00000000) Mask(00000000); RUNTEST 1000 TCK; ----------------------------------------------------------------------------------------------------------- I hope my question is clear, you help is appreviated Ehud Eliav
  2. Hi 1- I have the JTAG -HS2 device and i want to check that im using the API functions correctly, Can you recommand on a simple JTAG device which i can buy in order to check the JTAG-HS2 interface? The motivation is to connect the JTAG-HS2 to this device and simply communicate with its TAP. 2- Is there an option to configure the delay between the TDI/TMS rising/falling edge to the TCK rising edge (it is around 20 nS)? or this timing is fixed by the HS2 HW? for example when using the API function "DjtgPutTmsTdiBits(...)" Thanks in advance Ehud Eliav
  3. Hi Jon thanks for your support! i have managed to drive the JTAG pins. 1. Can you recommend on Digilent component that has JTAG interface so i will be able to connect it to the HS2 to verify communication with my script? 2.Do you know of a guidance how to wrap the Digilent SDK environment with Python ? (i have a Python based test environment and would like to integrate the API into it) Ehud
  4. Thanks Jon Regarding your question: Im connecting the HS2 to our own chip (real silicon chip that has JTAG interface) its not FPGA. but for the first setup, to understand how to use the API functions the HS2 is only connected to oscilloscope (i can watch the JTAG signals to verify the TDO, TMS are toggling...) he is not connected to any device, additional question :The "VDD " pin is voltage supplied by the HS2 outside? i measure there zero volts... Ehud
  5. Hi Jon pls. find my answers below: Have you used the DJTG and DMRG SDK examples provided? [Ehud]yes, I followed the instructions "Building an Adept SDK Project in Visual Studio.pdf " doc, shall i look into additional documents (Like programmer's reference)? Are you using a win 32 application with a win 64 bit architecture? [Ehud] my operating system is 64 bit ,so yes. Did you add the additional dependencies for each of the libraries as shown in the "Building an Adept SDK Project in Visual Studio" PDF? [Ehud] yes i did In addition - i think the DjtgDemo.cpp file is expecting to receive parameters , i didnt find the document describing what shall i send ... copy from the DjtgDemo.cpp ->"int main(int cszArg, char* rgszArg[]) {" running step by step... the program exit at the /* Command checking */ section .... Regards and Thanks Ehud
  6. Dear Jon I have received the HS2 cable, im trying use the SDK by using the DJTG and DMRG libraries . My project is to connect the HS2 JTAG pins to our chip (its a read chip , not GPGA) The adept2 recognized the HS2 cable. I have installed the following: System, Utilities and SDK . Im using Visual studio 2015 to execute the SDK code example. The Build (Visual studio) was completed without any error . Now im receiving the following errors in visual studio while executing: --------------------------------------------------------------------------------------------------------------------------------- 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Users\eeliavx\Documents\Visual Studio 2015\Projects\ConsoleApplication1\Debug\ConsoleApplication1.exe'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntdll.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\KernelBase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\djtg.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dmgr.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\dmgr.dll' 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\vcruntime140d.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbased.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\ucrtbased.dll' 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbased.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\user32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\win32u.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32full.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcp_win.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dpcomm.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\dpcomm.dll' 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.9317_none_508dca76bcbcfe81\msvcr90.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\version.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcrt.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dmgr.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dpcomm.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dabs.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shlwapi.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\combase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\rpcrt4.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sspicli.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cryptbase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\bcryptprimitives.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sechost.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\advapi32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\setupapi.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cfgmgr32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\imm32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel.appcore.dll'. Symbols loaded. The thread 0x9db8 has exited with code 1 (0x1). The thread 0x661c has exited with code 1 (0x1). The thread 0x89b4 has exited with code 1 (0x1). The program '[40600] ConsoleApplication1.exe' has exited with code 1 (0x1). --------------------------------------------------------------------------------------------------------------------------------- I assume im not sending the expected arguments to the program in visual studio? can you advise what are the next steps i shall do in order to toggle the JTAG IO pins (TMS,TDO,TDI...)? any specific document? Regards Ehud Eliav
  7. Hi Jon Do you have example or document that describe how shall i execute the environment? which parameters do i need to send? it does not appear in the "Building an Adept SDK Project in Visual Studio .pdf".... Thanks Ehud
  8. Dear Jon I have received the HS2 (same as Tifei ordered), similar to Tifei im trying use the SDK by using the DJTG and DMRG libraries . The adept2 recognized the HS2 cable. I have installed the following: System, Utilities and SDK . Im using Visual studio 2015 to execute the SDK code example. The Build (Visual studio) was completed without any error . Now im receiving the following errors in visual studio while executing: --------------------------------------------------------------------------------------------------------------------------------- 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Users\eeliavx\Documents\Visual Studio 2015\Projects\ConsoleApplication1\Debug\ConsoleApplication1.exe'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntdll.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\KernelBase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\djtg.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dmgr.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\dmgr.dll' 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\vcruntime140d.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbased.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\ucrtbased.dll' 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbased.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\user32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\win32u.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32full.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcp_win.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dpcomm.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\dpcomm.dll' 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.9317_none_508dca76bcbcfe81\msvcr90.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\version.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcrt.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dmgr.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dpcomm.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dabs.dll'. Module was built without symbols. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shlwapi.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\combase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\rpcrt4.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sspicli.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cryptbase.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\bcryptprimitives.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sechost.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\advapi32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\setupapi.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cfgmgr32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\imm32.dll'. Symbols loaded. 'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel.appcore.dll'. Symbols loaded. The thread 0x9db8 has exited with code 1 (0x1). The thread 0x661c has exited with code 1 (0x1). The thread 0x89b4 has exited with code 1 (0x1). The program '[40600] ConsoleApplication1.exe' has exited with code 1 (0x1). --------------------------------------------------------------------------------------------------------------------------------- Can you help pls.? what i did wrong? Ehud Eliav
  9. Im searching for a USB to JTAG controller/debugger (for reading and writing JTAG instructions ) in order to read and write internal registers in our design, My motivation is to connect to our IC (NOT FPGA is a real chip which contains ARM CPU and has a JTAG interface integrated) via 4 GP IO’s. I have checked your web site and found the below items suitable: 1- JTAG-USB Cable 2- JTAG-SMT2: Surface-mount are they suitable? Does the ADEPT SW have the ability to run a bit stream? Thanks in advance Ehud Eliav