MauroChimenti

Members
  • Content Count

    10
  • Joined

  • Last visited

Everything posted by MauroChimenti

  1. Hello, It's quite clear and "simple" understand how a new device driver is added in the sdk using the xilinx base libraries, but i i want to see the device in the /dev in linux. I don't know how link correctly this path, i suppose related to define the device tree and peraphs have a different driver code linux compatible. Where I can find documentation about that? Now i'm trying to see in the /dev the PmodGPIO, all work fine at the bare SDK level, but i don't see the device in linux. Thanks
  2. Hello all, I followed this guide : https://medium.com/developments-and-implementations-on-zynq-7000-ap/install-ubuntu-16-04-lts-on-zynq-zc702-using-petalinux-2016-4-e1da902eaff7 to install on the arty-z7-20 and ubuntu (ubuntu-14.04.4-minimal-armhf-2016-04-02.tar.xz) or debian (debian-9.4-minimal-armhf-2018-03-26.tar.xz) distribution from this site https://rcn-ee.com/rootfs/eewiki/minfs/. All steps are ok, and i have the prompt login on the usb serial or the ssh, but if i use ubuntu/tmppwd or debian/tmppwd , I can't access in both the distributions. At first the printed err
  3. Hello, After about a week of total disperation I discovered the reason of the issue. I have fast internet line about 100 Mbits and 5 ms ping. The reason of the build failure in related to the speed or better at the very slow ping. I really don't understand why but more Ilimit the speed or increase the ping up to 100ms the issue disappers. Actually a simply limited the VM Eth port with a netem rule: sudo tc qdisc add dev enp0s3 root netem delay 100ms
  4. Hello, I tried to upgrade python3 and git, but nothing is changed: Actually I have: python3.5 3.5.2-2ubuntu0 amd64 Interactive high-level object-oriented lang git 1:2.7.4-0ubunt amd64 fast, scalable, distributed revision contro The global git config is surely a clean empty one, because the VM is brand new (uhmm .. an empty git global config could be the issue). The global and system git configuration were empty. I created a base configuration but nothing is changed. --------------- .gitconfig --------------------------
  5. Hello, I restarted again.with a new VM this time with an Ubuntu 16.04.1 LTS, all configuration steps done without any error. Always the same results. In attachment the project conf file (Arty-Z7-20) cloned from the digilent repos. I attached even my printev because i'm sure the issue is related to something outside the project, for example enviroment vars or lib releaseas. I'm able to ping petalinux.xilinx.org, git://github.com/digilent/, git://git.linaro.org/ I think something related to the url with some vars inside example: PETALINUX_VER=2017.4 --> CONFIG_PRE_M
  6. Hello, Looking into the failure logs simply www.author.xilink.com is the last of tens mirrors tried, but the first one is the petalinux.xilinix.com. The issue seems not related to the project, because i tried many different projects and all have the same behaviour. More: I even tried to verify the installation and the system. using different petalinux versions with a xilinx reference project (xilinx-zc702) all in the same ubuntu 16.04.4 LTS and i had: version 2018.2 project xilinx-zc702 built successfully, version 2018.1 project xilinx-zc702 built successfully, version 2017
  7. Hello, After have studied all logs i noticed that the main problem is related to the site 'http://www.author.xilinx.com/sswreleases/rel-v2017.4/downloads/" First petalinux tries to download 'http://www.author.xilinx.com/sswreleases/rel-v2017.4/downloads/git2_git.linaro.org.toolchain.gcc.git.tar.gz, but it fails and after tries other mirrors . If I disable network access (in yocto petalinux-config) i have another error: gcc-source-linaro-6.2-linaro-6.2-r2016.11 do_fetch: Network access disabled through BB_NO_NETWORK (or set indirectly due to use of BB_FETCH_PREMIRRORONLY)
  8. Hello, I was just supposing that git clone --recursive .... should create a complete repository cloning with all subreps ready to be used. What does it mean "Set a MACHINE in you local.conf"? I have to specify what kind of board or zynq a have, or what else? I just checked under Petalinux-Arty-Z7-20/Arty-Z7-20/project-spec/meta-user/recipes-apps/digilent-apps/ and I have : gpioutil kmsdemo libgpio libpwm libuio libvrc pwmdemo but they aren't git reps , only one file inside them, the same related to the error. example : /Petalinux-Arty-Z7-20/Arty-Z7-20/proj
  9. Hello, I followed all indications for Petalinux-Zybo-Z7-20 (and some hints see here around): Petalinux 2017.4 , Brand new Ubuntu 16.04.3 LTS (VM in virtualbox) in details: After I created the VM i added all required libraries: ------------------ sudo -s apt-get install tofrodos gawk xvfb git libncurses5-dev tftpd zlib1g-dev zlib1g-dev:i386 \ libssl-dev flex bison chrpath socat autoconf libtool texinfo gcc-multilib \ libsdl1.2-dev libglib2.0-dev screen pax reboot -------------------- ALL OK sudo -s apt-get install tftpd-hpa chmod a+w /var/lib/tftpbo
  10. Hello, I have a problem quite similar to the one discussed in "Petalinux-Zybo-Z7-20 project doesn't build". I followed exactly all suggestions posted here and inside the Xilinx documentation, in brief: All libraries are been installed, bash as shell, a brand new 16.04.3 LTS ubuntu (even tried twice to be sure) . I tried to create the project by the BSP and/or cloning the repo. I even tried the suggestion posted in "Petalinux-Zybo-Z7-20 project doesn't build", but nothing is changed. I have errors and fetches failures: Many like these ones: --------------