Ildar

Members
  • Content Count

    4
  • Joined

  • Last visited

About Ildar

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thank you for your help, @JColvin. I cannot see any other reason here.
  2. I tend to think that I accidentally shorted MOSFET driver's 12V power input with PWM input while measuring voltage by multimeter (< 1 sec), what led to 12V at the FPGA's pin. However, all PMOD pins are protected from overvoltage by Zener diodes. Can it still be the reason of the problem?
  3. Hello @JColvin, thank you for your answer. - PGOOD LED is not turning on, I cannot see the board in Vivado. EDIT: Didn't check it in Device Manager (I will update this answer when I check it). Device manager doesn't see the device. - I connected total 13 pins to PMOD connectors: 6 ADC wires to PMOD JA for phases voltage sensing through voltage divider (3 diff pairs, they were connected some time ago and worked flawlessly); 1 ground wire between Zybo and BLDC motor control board - PMOD JE, ground pin; 6 wires for MOSFET drivers (4 grounds, 1 Vcc, 1 PWM; just started working with this control board and tried to align the motor with short PWM pulses) - ground and Vcc pins were connected to any free ground and Vcc pins of any PMOD, PWM wire was connected to PMOD JD-3. PWM and Vcc wires were at different phases. I would like to note again, that the motor was not connected and the only current in the control circuit flew through the voltage divider(microamps); - The battery was connected only to the control board to power MOSFETs and MOSFET drivers through their built-in DC-DC (~6 - 48V) -> 12V converter; - Voltage of the battery is 11.2V; - Zybo was powered via USB. After the failure I tried external power supply but with no luck; - To be honest I didn't check voltages of every power line but, at least, there are no short circuits. I did check 1.8V line via J13 pin with external 5V power supply and it was fine. EDIT: After unsoldering pass-through resistor R259, voltage at 3.3 side of the resistor became 3.3V as it should be. So the problem not in the ADP5052 (voltage regulator). Regards,
  4. Hello everyone and nice to meet you. I am a user of Zybo and until today everything was fine. But today I tried to use this board with a BLDC motor control board and something went wrong... The motor was not connected to the board, but battery was. The goal was to check correct operation of the MOSFETs (by PWM) at the control board and check it with oscilloscope. When I didn't see what I wanted to see, I turned Zybo off and back on, but it didn't turn on. The symptoms are as follow: - Short circuit between VCC3V3 and GND; - All other voltages are not short circuited; - The voltage converter seems ok too. Unsoldered R259 (zero Ohm resistor between converter's output and other circuit), but short circuit still remains. - Resistance of the pin used for PWM (to control MOSFET hi-driver) is infinite; - Zener diode connected to this pin changed its internal resistance as well (unsoldered it but it didn't change anything); - All other PMOD pins have finite resistance ~600 kOhm; - The PWM pin was surely connected to an input pin of the MOSFET driver. Is there any way to check if it is a permanent internal damage of FPGA without unsoldering it or not? I am pretty sure it happened because of that PWM pin but don't know why exactly. It might happen because of static discharge (though Zener diode should protect against it) or incorrect connection somewhere else by accident. Thank you for your time. Hope to get some hints soon. Regards,