Emma_12

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. Hello, I'm working on a school project with the Digilent Pmod BT2 and I'm having problems trying to change certain settings while in command mode as well as using the inquiry command. My goal is to initiate bluetooth connections from the pmod BT2 module while in master mode rather than to have to initiate the connection from the secondary bluetooth device while the module is in slave mode. I'm using the application putty for my command line, and I am able to enter command mode just fine (I type in $$$ and receive CMD back) but when I try to change the authentication settings I enter SA, 0 <enter> and I receive AOK back, but then I am unable to type anymore in the command line and I am forced to quit out of the application and restart putty and re-enter command mode. As far as I know, I am not actually successfully changing the authentication setting because I am unable to properly reboot the module. This problem also occurs when I try doing an inquiry - I get the correct results back from the inquiry but then I am unable to make any further commands. Additionally, I am unable to successfully connect to other bluetooth devices while in master mode. I type in C,<MAC address> <enter> but I receive back ERRxxxxxxx the x's being part of the MAC address I entered in. I think this is because I am don't have 0 as the authentication setting, but since I cannot change that setting I don't know for sure this is the problem. Thank you in advance for your assistance. Sincerely, Emma