anzunden

Members
  • Content Count

    4
  • Joined

  • Last visited

About anzunden

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi @jpeyron, thank you again for answering. So I've followed the solution on that link which shows the new run configuration. After I use that configuration, the program not get hung again! Now it worked until the end of the program. Thanks!
  2. Hi, I want to run simple DMA transfer (not using scatter gather) application program on the attached design. But the program is always hung when running XAxiDma_CfgInitialize(&AxiDma, Config) function. The JP4 jumper is set on QSPI mode and the running configuration mode is like the figure I attached. The same program is run and not hung on XAxiDma_CfgInitialize(&AxiDma, Config) if ran on ZYBO. But, with differences in run configuration mode. On ZYBO run configuration mode, I'm not using the initialization file and so not run the ps7_init. On Arty Z7 I need to use it, because if I'm not using it the internal error (No target with ID 64 in the system) will be occured. What should I do?
  3. Hi @jpeyron, thanks for answering. I've solved the problem, there is wrong configuration on the ZYNQ processing system IP. Before using Arty Z7, I'm using ZYBO. There are some differences between them, The ZYBO DDR bus width is 32 bit, whereas Arty Z7 DDR bus width is 16 bit. So after I made some configuration editing, to change the bus width from 32 bit to 16 bit, like the figure I attached, the application program can run. My fault is I'm not using the preset board setting when running the ZYNQ PS IP block automation. Thank you
  4. Hi, I've got some error while trying to download .elf file to Arty z7-7020. The error I get is like this An internal error occurred during: "Launching New_configuration". No Target with ID 64 in the System ERROR : Unexpected error while launching program. java.lang.RuntimeException: Failed to download ELF file AP transaction error (DP CTRL_STAT=0xf0000021) Error Address = 0x00100000, Size = 0x00000004 at com.xilinx.sdk.targetmanager.internal.TM.downloadELF(TM.java:686) at com.xilinx.sdk.debug.core.internal.AppRunner.run(AppRunner.java:129) at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.runApplication(XilinxAppLaunchConfigurationDelegate.java:637) I've follow some solution in other forum such as set the initialization file ps7_init.tcl and check to run the ps7_init, and I've check the JP4 jumper to set the operation mode (set as JTAG, or sometimes as QSPI) but the problem still persist. For the design I run, I only use ZYNQ7 processing system to run the hello_word application example. Why can this happen? plz help