Assane

Members
  • Content Count

    6
  • Joined

  • Last visited

Everything posted by Assane

  1. Hahaha ! You're right it is really cool @D@n ! Keep it up ! I hope I'll also be called that soon 😄 ! Assane.
  2. Hi @D@n, yes I meant "lsusb" earlier, not "libusb" sorry. And finally, I got it working ! It was because "ibftdi" library wasn't installed correctly. I did it manually and I didn't noticed the mistake since the compilation never mentioned anything wrong. The /etc/udev/rules.d directory does contain digilent rules file with the right permissions. Thanks a lot Dan, Colvin, Jon ! Best regards, Assane.
  3. Hi @jpeyron, Thanks for the prompt reply. I'll be waiting. Yes i've also tried the EnumDemo sample and it does not print out any device. Regards, Assane.
  4. Hi again ! The DmgrEnumDevices() function keeps returning 0, but when I use the Linux command "libusb", the cable is in the listed names of devices. It is not easy to debug the problem because the source code of the library is not public (I presume), and the function doesn't report any information. Do you think it's an issue of driver (libusb1-0 and liftdi) or the adept runtime wrongly installed ? Or anyhting else ? Thanks again !
  5. Hi Colvin, Sorry for my late reply... I was busy with something else, but i promise i'll try your suggestion and come back to you as soon as i can. I believe the DmgrEnumDevices() will resolve my problem and i missed it. Thanks a lot Colvin !!
  6. Hi everyone ! I'd like to use the JTAG-HS3 cable to work on a project which consists in testing several interconnections between devices on a board. I'm using DJTG and DMGR APIs and i'm connected via ssh to the computer which has the cable plugged on. My question is: How do i connect to the board with the DMGR API? I know that i have to use DmgrOpen() function but it requires a "device name", which i don't have. Thanks in advance ! Have a nice day !