Carlos Posse

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. Hello, It did, that solved it. I can now program the SoC through USB and open a UART port. On a first analysis I only checked if I had indeed loaded the ferrite beads. This time, I checked the characteristics and they had a resistance value of 120 Ohm, which I reckon should not be used in a USB interface. Thank you very much, Carlos Posse
  2. Hi @jpeyron No, I don't have the RTS or CTS signals connected to anything. I have attached the VBUS detect, just forgot to include it in the above schematic, here's the missing part: Thank you, Carlos Posse
  3. Hello, Thank you for the help. Below are the screenshots you asked. The Zener Diodes in the schematic were selected for 1.8V.
  4. Carlos Posse

    JTAG-SMT3 Problems

    Hello, I am using a JTAG-SMT3-NC module in a new design with a Zynq 7020, and am having problems connecting using USB. The design also features a JTAG header, with connections according to the SMT3 Reference Manual. The JTAG header works, and is capable of programming the board using a JTAG-HS3 cable. However, no USB ports are detected, nor the JTAG part is detected. I am using Ubuntu 16.04, and quick check to dmesg shows the following messages: [ 899.622004] usb 3-1: new high-speed USB device number 17 using xhci_hcd [ 899.750007] usb 3-1: device descriptor read/64, error -71 [ 899.986072] usb 3-1: device descriptor read/64, error -71 [ 900.222052] usb 3-1: new high-speed USB device number 18 using xhci_hcd [ 900.350076] usb 3-1: device descriptor read/64, error -71 [ 900.590093] usb 3-1: device descriptor read/64, error -71 [ 900.698132] usb usb3-port1: attempt power cycle [ 901.353659] usb 3-1: new high-speed USB device number 19 using xhci_hcd [ 901.353727] usb 3-1: Device not responding to setup address. [ 901.560275] usb 3-1: Device not responding to setup address. [ 901.766579] usb 3-1: device not accepting address 19, error -71 [ 901.893702] usb 3-1: new high-speed USB device number 20 using xhci_hcd [ 901.893779] usb 3-1: Device not responding to setup address. [ 902.100134] usb 3-1: Device not responding to setup address. [ 902.310523] usb 3-1: device not accepting address 20, error -71 [ 902.310571] usb usb3-port1: unable to enumerate USB device As seen, both the USB devices (the UART and JTAG parts) are detected, but are unable to be configured. I have the cable drivers installed and updated with the Vivado 2018.2 drivers. The SMT3 module is powered by an on-board 3.3V regulator, while VBUS is only used for VBUS_DETECT. The multimeter shows 3.3V on the VBUS_DETECT pin when I connect the USB cable. Any ideas on what this can be?
  5. Hello, I'm currently building an UAV with tight mass restrictions, and am considering using a PYNQ-Z1 board. I can't find the mass value for this board on any documentation though. Could you please point me to it if such information exists, or provide me with the value ? Thanks in advance, Carlos Posse