analoghb

Members
  • Content Count

    2
  • Joined

  • Last visited

About analoghb

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thank you Jon. I also used that software in part. Last night I managed to communicate with PmodAD5. When I make progress I will post it here.
  2. Hi, I'm trying to make PmodAD5 work with a Zedboard by using Vivado 2016.2 (can also use earlier versions if needed). Digilent has a nice wiki pages to use Pmods with Zedboard, especially for using Pmod IPs: https://reference.digilentinc.com/learn/programmable-logic/tutorials/pmod-ips/start In this tutorial, however, there is no PmodAD5, and there reference design linked from Digilent product page to AD also has the implementation example for Xilinx ISE 14.4: https://wiki.analog.com/resources/fpga/xilinx/pmod/ad7193 Nevertheless I tried to combine the information I could find to start with a ZYNQ7 Processing System with AXI Quad SPI IP. (I managed to work with that way with a MAXIM Pmod temperature sensor). But I got stuck at some point as to communicating with PmodAD5 device. After HW and SW implementation I am getting the following output on the UART: Status Register: 0x0 Mode Register: 0x0 (The second one should be different than 0x0 according to documentation) Is there someone out there tried PmodAD5 with Zedboard who could help me? Since this is my first post I tried to explain the overall status. If there are questions specific to the project I am more than happy give additional info. Thanks.