dakefeng

Members
  • Content Count

    45
  • Joined

  • Last visited

Everything posted by dakefeng

  1. ignore that warning. I remember I read explaination somewhere. It doesn't matter at all
  2. make a simple VGA scan logic, takiing care of the sychronization and then output RGB value. since your image is not some standard resulution, can you make your image 800x600 and put the image in the center? you can use fifo to fill it.
  3. Unforturnaly it doesn't work. u32 addr=Bram.Config.MemBaseAddress; int cnt=0; while(cnt<10){ xil_printf("At addr: %x\r\n",addr); XBram_Out32(addr,0x7fff); xil_printf("done%d\r\n",cnt); addr++; cnt++; usleep(100); } The program hangs at the second try of XBram_Out32 calling. How can I fill the memory? Thanks a lot.
  4. Just noticed that selftest program example is for ECC only, without enable ECC like what I did, it does nothing just return successful.
  5. Dan, I am now starting from standalone application instead of linux application. I guess the address is not virtual one, by Xil_In32 call?
  6. Made a simple zynq project, a small bram in PL and an axi bram controller connected to its port. The axi ip routed to axi interconnection without any complain. At SDK import a test BRAM application and it shows pass test. But I am still very confused how to access the data and addr in the BRAM. The AXI memory base add is 40000000 and high is 4000FFFF, does that mean this is the memory address range I need to read and write? Thanks, Dake
  7. As I mentioned days ago, I made a java version GUI for the Adept2 command line tools on linux. Please try it out and tell me if it is usable or useful. Many thanks, Dake Feng JAdept2-2016-7-16.jar README src-2016-7-16.tar.gz
  8. Any news on GUI of adept2 running on linux? The windows version is quite nice and simple. I am already spoiled. We may do Qt, Java, FLKT, and so many widgets toolkits to play with. If nobody is making one, maybe I can do a simple gui...
  9. Thanks, I found the script under kernel tools dtc, it works like magic ~/gits/linux-xlnx/scripts/dtc/dtc -I dtb -O dts -o devicetree.dts devicetree.dtb
  10. dtb is binary blob file of the device tree, how can i get the source device tree readalble? Thanks
  11. yeah, after i tried to make ubuntu working on zybo, I am thinking maybe I can figure out how to install X on genesys 2 some day too!
  12. Thanks, 1144 and so on, I have ready read for almost hundred times. Just realize that now I am already out of petalinux doc, it is the time that I should look for linux programing, kernel, modules and so on. I've dealt with gpio part, it is standard way through sysfs, not special structure. It works great so far,thank you.
  13. http://xillybus.com/xillinux/ Anyone tried this one? it says work for zybo too.
  14. Now I want to play with gpio. The gpio_demo.c has some simple remark on how to find the gpio_base from /sys/class/gpio. but that was much too simple. From google the only resource I can locate is http://www.wiki.xilinx.com/Linux+GPIO+Driver Do you have some better and well orgnized document? like pdf I can download and read it when I do not have internet? Thanks.
  15. great, and I found out my mistake, i guess that is because I didn't set petalinux rootfs when new an application project. Thank you very much
  16. now my zybo boots up flawlessly, it is time to develop linux application.. But questions ... 1. I can use sdk to make elf executable program and copy to the board to run it. but it is really awkward. 2. I am trying to document ug1165 but still have no idea how it should work. I thought it should work like un the app and printf to console and so on... but nothing happened Now my situation is zybo at 192.168.3.10, running good. it was booted from virtual machine ubuntu via jtag. I can telnet to zybo or use usbtty to access shell in virtual machine. next I start a new applicat
  17. For 1 I have done a lot already. I use the simplest board design, only two gpio connect to switches, buttons and leds. then use petalinux made a projection with this hard ware to start. I set up busybox httpd service, linux app to work show the switch button status and light the leds. I even made a BSP release for the design. The interesting thing is I noticed zybot project, I just do not understand how the linario make the x working from the zybot perpherials. I hope I can just rip some simplest framebuffer or something to support a very simple xwindows and manager
  18. mine was always same, but it would be helpful to check dmesg log to see the device node.
  19. the usb cable is not special one, any one should fit. I suggest you use vivado 2015.4 with ubuntu 14 or 16. my vm is parallel works good. usbtty1 should be the uart, open a console at 115200/n/8/1 when the board powered on. make sure the boot should be set to jtag before use sdk to program the zybo board.
  20. I want to use zybo to make a simple linux box, which can take usb keyboard as stdin and vga/hdmi as text console stdout, and later on I want to make it support usb mouse/keyboard and vga/hdmi as Xwindows console. The first thing would be to design the vivado project, what IP core I will be needing? best to be open source/ free/ with linux driver and so on. Anyone please give me some hints or direction I will try my best to do it. Thank you.
  21. ok, I brutally make a link from /bin/sh to /bin/bash.
  22. When I am doing petalinux-config, I got error like this: $petalinux-config INFO: Checking component... INFO: Config linux [INFO ] config linux *** End of the configuration. *** Execute 'make' to start the build or try 'make help'. /bin/sh: 1: pushd: not found /bin/sh: 1: popd: not found make: *** [post-config-auto-config] Error 127 ERROR: Failed to post config linux ERROR: Failed to config component linux Usually this is because shell not bash, but I am pretty sure I am using bash.. Unless the ubuntu 16 is using dash??? in my /etc/passwd it shows my shel
  23. Spent 50$ to upgrade my parallel to 11, installed ubuntu 16.04, redo everything. it is connected now. still haven't found the problem. BTW what is the device name for digilent fpga program cable under /dev?