macethorpe

Newcomers
  • Content Count

    6
  • Joined

  • Last visited

  1. [email protected], thanks for the help, it turned out to be really stupid - the dialog wasn't big enough to render the check boxes (although it certainly looked like it had enough room). I stretched it way out and they magically appeared. Probably due to my hires screen and java not playing nicely. Another interesting thing along the way - there is a way to export a TCL script that supposedly builds the project. The options are all available in that script for tweaking, but not needed now. As you say, it also would have been straightforward to edit the .bit files. There is a string of FFs near the beginning. Everything before that is header. Thanks again, you saved me a lot of frustration.
  2. Thanks, I appreciate the help. So did you see the same as my screen shot but with check boxes? If so I'll probably try to reinstall Vivado.
  3. Yes, everything else works. I think the option you mention was the checkbox shown in the tutorial for the "-bin_file" option associated with "write_bitstream". The GUI of Vivado has changed, but the only similar thing I can find is in project manager/settings/bitstream. "-bin_file" option is there, but there is no button or checkbox. See attached image in the original post.
  4. [email protected], thanks, good tip, that would have been my next problem. However, Vivado is still not making a .bin file. The problem seems to be earlier in the process. My thread title may be a bit off.
  5. I'm using 2020.1. No problem programming through JTAG.
  6. Folks, I am following the arty programming guide to program an Arty A7 using the quad SPI flash. https://reference.digilentinc.com/learn/programmable-logic/tutorials/arty-programming-guide/start The guide shows a project settings/bitstream dialog allowing you to turn on -bin_file when generating the bitstream. My version of Vivado does not have checkboxes on this dialog, so I can't seem to turn it on. Any advice? Thanks