calebdougherty63

Newcomers
  • Content Count

    1
  • Joined

  • Last visited

  1. Hello, my name is Caleb. I am a senior electrical engineering student at Northern Illinois University. I am using the Analog Discovery 2 in order to capture analog pixels sent from a sensor at 5MHz and then interpreting that data on the Raspberry Pi 4. I am running into questions with the timing of the logging function of the oscilloscope on the Analog Discovery. I have noticed that when I send multiple acquisitions at once I run into issues with the timing on the next acquisition. It seems that each acquisition comes in order, but there is a delay between the end of one and the beginning of the next. For example, the time from the first sample to the last would be about 1.6 ms elapsed time. However the next acquisition would have a DateTime listed that is 50 ms later than the previous aquisition. My current settings I have been using are: Scope mode - Repeated Buffer: 10 (Not sure from the source material how this impacts acquisitions..) Logging Execute: Each acquisition 8192 samples Is there a way to have the acquisitions send the data out so that the end of acq0000 would correspond to the data at the beginning of acq0001? An additional question I have is how the AD2 Date Time function is working in the csv files exported as acquisitions. Is it a real time clock on the AD2 or is it information pulled from the pc/rpi? Thank you for any help you are able to provide on this. I can provide further information if it is needed.