• Content Count

  • Joined

  • Last visited

  1. Those worked. I just had to manually install libgles2 after Waveforms. Looks like at this time, the Chromebook Linux support of USB devices is pretty limited, so my Analog Discovery2 isn't detected. Support may be added as early as this summer, so I'll give it a try again then. Thanks for the help!
  2. Hello @attila Thank you for the prompt response. Forcing the install lead to some good learning opportunities. Here is what I found: The architecture of my machine is arm64. So there was a conflict in trying to install amd64 packages and I think the architectures are so different, it wouldn't run even if it installed. I assume this is why it was flagging that I didn't have the right version of libc6 installed, because I had arm64 version and it was looking for amd64 version. Thinking that an ARM build of the applications would work, I downloaded the waveform and adept installs for armhf architecture. I added armhf as an architecture using: sudo dpkg --add-architecture armhf sudo apt-get update I was then able to install the armhf versions of adept runtime and waveforms. However, when I try to run waveforms, I get the error: /usr/lib/digilent/waveforms/waveforms: error while loading shared libraries: cannot open shared object file: No such file or directory I believe this is because the armhf installs are 32 bit (located in '/usr/lib' not '/usr/lib64') and my libstdc++6 libraries are 64 bit. To address this, I installed the 32 bit libraries, using; sudo apt-get install lib32stdc++ I still get the same error that cannot be found. Since neither install is really made for arm64 architecture, maybe this isn't possible. I have a Win10 machine that Waveforms works well on, so no problem continuing to use that. I just thought it would be cool to get it running on my Chromebook. Thanks!
  3. I'm fairly new to Linux and Waveforms, so apologies if I am missing something obvious. I am trying to install Waveforms on a Chromebook with Linux support enabled. The version of Waveforms I am attempting to install: digilent.waveforms_3.12.2_amd64.deb The version of my OS: $ cat /etc/*-release PRETTY_NAME="Debian GNU/Linux 10 (buster)" NAME="Debian GNU/Linux" VERSION_ID="10" VERSION="10 (buster)" VERSION_CODENAME=buster ID=debian The error I get when trying to install: The following packages have unmet dependencies: digilent.waveforms: Depends: libc6 (>= 2.14) but it is not installable Depends: digilent.adept.runtime (>= 2.17.1) but it is not installable So, it seems like dependency issues. I checked my version of libc6 and it is greater that 2.14. $ apt list libc6 Listing... Done libc6/stable,now 2.28-10 arm64 [installed] I have separately downloaded Adept 2 runtime version digilent.adept.runtime_2.20.1-amd64.deb. I get the following error when trying to install it. The following packages have unmet dependencies: digilent.adept.runtime: Depends: libc6 (>= 2.5) but it is not installable So, this seems like I need libc6 2.5 or greater, but I can't seems to find any higher version. So, I feel like I'm in a recursive loop. Any help is appreciated. Thanks!