BlueHorse

Members
  • Content Count

    2
  • Joined

  • Last visited

Posts posted by BlueHorse

  1. I solved that issue,

    according to

    http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_7/SDK_Doc/tasks/sdk_t_linux_application_debugging_system_debugger.htm

    and page 80 at this

    http://china.xilinx.com/support/documentation/sw_manuals/petalinux2014_4/ug1144-petalinux-tools-reference-guide.pdf

    the assumptions claim that you have "tcf-agent" running on target (i.e. zybo), the ramdisk i was using is the pre built one here

    http://www.wiki.xilinx.com/Build+and+Modify+a+Rootfs

    the ramdisk shipped with petalinux zynq releases has tcf-agent and you can use it along with whatever image you compiled previously

    http://www.wiki.xilinx.com/Zynq+2015.2+Release

    if you prefer building your TCF-agent from scratch, you may try this

    https://wiki.eclipse.org/TCF/Raspberry_Pi

    Note that zynq machine is armv7l

     

     

     

  2. Hello guys,

    I followed this tutorial "Embedded linux on zybo" http://www.instructables.com/id/Embedded-Linux-Tutorial-Zybo/

    and everything works like a charm, I compiled the linux kernel and u-boot from digilent github, as a next step I said i'll be debugging Linux C apps.

    I'm trying hard to debug a linux application coded in xilinx SDK (2015.1) according to the follwoing two links:

    http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_7/SDK_Doc/tasks/sdk_t_linux_application_debugging_system_debugger.htm

     

    what happens that when i try to press Debug, i got in the debug perspective .. "Target does not support Processes service"

    Am i supposed to use different Linux kernel (i.e. Petalinux) or Am is supposed to use different uramdisk ?

    Please let me know what am i missing???