birca123

Members
  • Content Count

    19
  • Joined

  • Last visited

About birca123

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi @jpeyron, @zygot, Thank you Jon, for the link. @zygot yeah, you are right, I'm not using flow control. Actually, I'm sending a binary image in a way that 8 pixels are sent per data package, so 8 times less bytes are sent. Maybe the problem is in processing the data on the PC side after a byte is being received. I will try to solve it with receiving all data first and after that processing all received data. If it won't work I'll implement the flow control, also my goal is to use 921600 buad without issues. Best regards, Toni
  2. Hi @jpeyron, I can't see the article. Can you please link it again? Best regards, Toni
  3. Hello, I’m having problems with sending large amount of data from ZYBO to a computer. For example, when I tried to send image data (640x480) at the maximum baud rate, the computer didn’t receive all data. But when baud rate was set to 256000, all data were received. It seems like UART buffer is overflowing. How to solve this problem? Best regards, Toni
  4. birca123

    ZYBO Image Processing

    Hi @jpeyron, Thanks, it's helpful. Best regards, Toni
  5. birca123

    ZYBO Image Processing

    Hi @jpeyron, as I said before, I'm not using any OS so it's baremetal/standalone application. I have found somewhere that OpenCV can't be used in that case, and I'm looking for an alternative library that can be used for example for writing text on images and drawing objects, etc. Best regards, Toni
  6. birca123

    ZYBO Image Processing

    Hello, is there any image processing library that can be used for standalone applications on ZYBO? Thanks, Toni
  7. birca123

    ZYBO HDMI-IN

    Hello, I have a problem with the HDMI-IN example for ZYBO. As an input, I'm using FPV camera which has an analog output, and between the camera and ZYBO is AV2HDMI converter, which upscales NTSC resolution to 1080p or 720p HDMI signal. The problem is that ZYBO says that video capture resolution is 3996x5 when the output resolution from the converter is 720p and 3996x0 when the output resolution is 1080p. When I connect the camera to the TV as HDMI source, everything works perfectly. Is this solvable? Or should I use another HDMI source for this example? Best regards, Toni Birka
  8. Hi @jpeyron, ok, thanks. Just let me know if you find out something. Best regards, Toni
  9. Hi @jpeyron, Sorry for the late response, I'm busy these days. The problem is that I've never used ILA modules before and it would take time for me to understand it. Can you check it real quick? The project files are available on the following link: https://www.dropbox.com/s/tjd21flsmxn650i/ZYNN_project.rar?dl=0 I appreciate your help, best regards. Toni
  10. Hello, My application freezes after I run the self-test for a video timing controller. What is the cause of the problem? The used Block design is shown below. Best regards, Toni
  11. Hi @jpeyron, Thanks Best regards, Toni
  12. Hello, I'm trying to make a standalone application for image processing on ZYBO, but I have problems with creating a block design which would make it possible. Since I started using Vivado two months ago, I'm still not familiar with creating my own block designs. I know that I should use dvi2rgb, Video In to AXI4-Stream and AXI VDMA IPs to store frames to DDR memory, but I don't know how to configure them. My idea is to create a function in Vivado SDK, e.g. CaptureImage(), which would return an address of the image saved in memory. Can somebody help me create the simplest block design to accomplish that? Best regards, Toni
  13. Hi @jpeyron, Thanks a lot for helping me. Now it's working every time I run the application. I will try to modify it to make it work in my project, I hope to succeed. Best regards, Toni
  14. Hi @jpeyron, Ok, I understand. I program the FPGA, run the application, it works perfectly for the first time, but if I run the application for the second time I'm not getting the image from the camera. It only displays one of the test patterns. I got the same problem when I run the 2016.4 project, after updating IPs and changing iic to IIC and dcc to DCC inside of .xdc file. Actually, the reason why I'm trying to make this work is that I want to implement NN on ZYBO to recognize handwritten digits from an image taken from a camera which should be connected via HDMI. NN works fine when I send an image via UART, but now I should get an image from a camera. Since I started using Vivado two months ago, I'm still not familiar with creating my own block designs except the basic ones so the block design of HDMI_IN example seems complicated to me. Do you know what's the best approach to get an image from HDMI or which IPs should I use and how should I configure them? Is there any guide or tutorial on how to accomplish that? I've found a few projects with HDMI input, but mostly they run Linux OS on ZYBO which is not actually what I'm looking for, I would like to make a standalone application. Best regards, Toni
  15. Hi @jpeyron, I got the same errors when I did that, errors from SDK Log are shown below. There's also an error: "Program "arm-xilinx-eabi-gcc" not found in PATH". This happened when I regenerated bitstream, but when I used the bitstream which you generated it worked. I was able to see the serial terminal menu on Tera term and there was an image from my GoPro camera on the VGA device. Best regards, Toni