CaptIgmu

Members
  • Content Count

    8
  • Joined

  • Last visited

  1. Hi @kwilber, In my project, I used the Board tab in block design to configure all ports and realized I did not need a separate Digilent.xdc constraint file so none were added as source.
  2. Hi @kwilber, Thank you for your explanation. I see the Arty A7 board has been around for a while and I was hard pressed to believe the board.xml file could be wrong this long! Looking through the forums, I see some users having problems getting the UartLite to work and others no problem. I must have a special case because I could not get my design to work until I changed the FPGA direction of TxD and RxD. I will have to try some more projects and try the 16550 uart as an alternative also. Initially I was thinking of a github pull request to change the board.xml file but realize now I should let this go . . . Thanks again for your input, -Ron
  3. Hi @jpeyron, My cable drivers for Linux are installed properly, I've been able to program the Artix-7 FPGA on the Arty A7 board by USB from my PC. That is not the problem. The question is whether the board files need to be corrected for pin direction of TXD and RXD for the Arty boards when adding a usb_uart port to a design. I changed my board.xml file, it works, I'm just thinking about new Arty users . . . Thank you, -Ron
  4. I'm using the Arty A7-35 board and have been going through the tutorials and built a MicroBlaze soft processor with a UartLite serial port using Vivado 2018.3 on Ubuntu 18.04 LTS. It did not work! Looking through the Arty A7 Reference Manual I found this: and looking at this diagram: Then the Artix-7 A9 pin should be configured as an input and the D10 pin as output. But here is the usb_uart interface spec in the ./board_files/arty-a7-35/E.0/board.xml file : <interface mode="master" name="usb_uart" type="xilinx.com:interface:uart_rtl:1.0" of_component="usb_uart" preset_proc="uart_preset"> <preferred_ips> <preferred_ip vendor="xilinx.com" library="ip" name="axi_uartlite" order="0"/> </preferred_ips> <port_maps> <port_map logical_port="TxD" physical_port="usb_uart_txd" dir="out"> <!--Change to “in”--> <pin_maps> <pin_map port_index="0" component_pin="usb_uart_txd"/> </pin_maps> </port_map> <port_map logical_port="RxD" physical_port="usb_uart_rxd" dir="in"> <!--Change to “out”--> <pin_maps> <pin_map port_index="0" component_pin="usb_uart_rxd"/> </pin_maps> </port_map> </port_maps> </interface> So, usb_uart_txd should be "in", usb_uart_rxd should be "out". When I change this, the UartLite serial port works! I tried to change the direction of the pins in the Project HDL "wrapper" to no avail. Please note that this default config is found in the board.xml files for arty, arty-A7 and arty-S7. Do the board.xml files need to be changed? Is there some other way to change pin direction in the Vivado Project?
  5. Hi @jpeyron, Thank you for your input! My problem was not usb and cable drivers. The Hardware Manager was able to see my board and djtgcfg enum correctly listed my board. My problem was my confusion about where I could pick my arty-a7-35 board!
  6. Hi @kwilber, Thank you for your input! Vivado 2018.3 does work with Ubuntu 18.04 LTS. My confusion came when I did not start with a simple project like blinky. Instead, in the Vivado Quick Start, I selected Open Example Project and tried to do the Base MicroBlaze example. In these templates you can only pick a default Xilinx development board but later in your Project settings you can select your Digilent board but then need to change your IP . . . it is a pain. Instead, if I pick Create Project in the Quick Start, I can then select my arty-a7-35. Also, the Vivado_init.tcl startup file does work and I don't need to add the Digilent board files to .../data/boards/board_files/. The other key issues with Ubuntu 18.04 LTS: don't use sudo to install Vivado but do use sudo to install the cable drivers!
  7. I just purchased the Arty A7 board and have been following along with the tutorials and installed Vivado 2018.3 WebPACK on Ubuntu 18.04 LTS . I also set up the cable drivers, Digilent boards from github and the Vivado_init.tcl for startup. Alas, Vivado defaults to Xilinx development boards and I can't pick my Arty-A7 board (not on the list). Even if I put the board file directly in . . ./data/boards/board_files as per the instructions, Vivado can't find it. I have tried changing file permissions, renaming files, moving files to different folders and even tried to "sneak" the arty_a7_35 files into the existing ac701 folder to no avail. Made no difference with or without a license and Digilent clearly states in the docs: "Most people don't need a license." Looking at the Digilent and Xilinx forums, this inability to recognize the Digilent board files in Vivado is a recurring theme with some solving it and others . . . not! The saving grace is that the Hardware Manager sees my board, I just can't use it yet. I would appreciate any help so I can get started with this very interesting board.