All Activity

This stream auto-updates     

  1. Past hour
  2. Today
  3. Thanks for respond: Do you have any source where exactly performed those process (cross-compile) for sdr adrv9361 board or any other fpga board?
  4. Hi @Serdar You could use a custom Bus and import data from file (up to 32k/channel) or use Script to generate custom pattern or parse the imported data.
  5. Hi @m72 After adding the Order option in Logic Analyzer (splitting the Input selection in two) I have forgotten to update the Protocol/Logic Analyzer to set the Order option automatically. Thank you for the observation, it is fixed for the next release.
  6. Hi @m72 This looks like a digital issue in the ADC. Have you used for this tests the WF v3.11.23 I sent you in private message?
  7. Hi @Grant Edwards It is not possible to analyzer scope data as protocol, but the Logic Analyzer and Protocol tool supports inverted option for UART.
  8. I use iTunes and Nexys both for watching videos. According to me, iTunes is a better option for videos(1080p). Though I faced some issues while using iTunes but by following https://itunessupport.org/blog/how-to-restore-iphone-without-updating/ I got the proper solution.
  9. Yesterday
  10. I am using pmod i2s2 and it is working fine with transmission data , Now I need to use it as a RX from an external mic I use this converter to use my normal headphone for both mic and speaker, and Iam trying to loop back the data I recorded , I use MCLK = 25 MHz , LRCLK = 48.8K hz , SCK = 3.128 Mhz (and these clocks are configurable) but I donot hear anything of the recording data. should I use an amplifier ? or should I configure anything else other than the clocks Pmod is operating as slave
  11. Hi @jpeyron, Apologies for the delayed response. I have gone through the HTMLGetPins.cpp file and created a similar one for ALS called HTMLGetAls.cpp I am getting few errors(please find the screenshot). These are the sequence of steps I've followed: 1. Created a GET request to PMODALs.htm (A dynamically generated page, similar to PinsPage.htm) " static const char szHTMLGetPMOD[] = "GET /PMODALS.htm "; " in deWebIOServerSrc.cpp 2. Add HTML Page using the existing function (similar to ComposeHTMLGetPINS) " AddHTMLPage(szHTMLGetPMOD, ComposeHTMLGetALS); " in deWebIOServerSrc.cpp 3. Created HTMLGetAls.cpp to get ALS data (light value). Attached Files Content: 1. HTMLGetAls.cpp - cpp file to read als data and display on web page(auto refresh every few seconds) 2. HTMLGetPins.cpp - auto generated cpp file. I've used this file as a reference to create HTMLGetAls.cpp 3. deWebIOServerSrc.cpp - controls the entire flow of the process 4. HTTPServer.h - contains the structure CLIENTINFO_T which controls the sequence of events 5. PmodALS.c - Used for ALS 6. PmodALS.h - Used for ALS Thanks for support. Regards, Asha Devi HTMLGetAls.cpp HTMLGetPins.cpp deWebIOServerSrc.cpp HTTPServer.h PmodALS.c PmodALS.h
  12. Hi, I have an XC3S400 based board I am prototyping some thing on. I find that if I program the FPGA with djtgcfg it appears to work (command success, done LED cycles etc) but the design is hung. If I use the same programming tool via impact and the Vivado hw_server it works fine. Any suggestions what I may be doing wrong? Thanks
  13. Last week
  14. Hi J, Thanks for your prompt response. I assume that would be a cable like so: https://store.digilentinc.com/2x6-pin-to-dual-6-pin-pmod-splitter-cable/ I've never programmed a MCU before. I assume it shouldn't be too hard to write code to bind the peripherals to the MCU pins, I hope.
  15. Yacov Cohen

    AD7193

    Please let me know if there is a solution to work with 8 inputs on AD7193. In the past you tried to find a solution
  16. Hai, bitstream generation is successfully completed when i add few lines of code in my previous xdc to the latest one you provided. And i got output on display. but i m not sure whether this is the correct one.
  17. I believe that there is a bug in that particular version of the dvi2rgb decoder. A workaround would be to just set the TMDS clock range parameter to ">= 120 MHz". Alternatively, you could replace the core in the project's repo folder with the latest version of that IP, which has resolved that bug, found in this ZIP. Thanks, Arthur
  18. This error is likely related to the rgb2dvi IP. Please send a screenshot of its configuration (see below).
  19. thanks for the reply but now i got error while implementation error. error snapshot attached.
  20. I am interested in the digital pattern generation feature. Can it take data from an ascii test file, one byte per line and output/play it to the IO? If yes, can I specify the clock rate at which this data from the file will be played out? Thanks.
  21. Looks like the project was just missing constraints. I am unsure what the root cause of the problem is, but I managed to generate a bitstream. Download the attached XDC file and add it to your project. Thanks, Arthur Zybo-Z7-Master.xdc
  22. Hello! Digital Discovery, WaveForms from 3.11.18, Windows 7 x64. When allow "Logic Analyzer" from "Protocol" by default it change DIO24 -> DIN0 (mode 800 MHZ, DIO0..7). If start "Logic Analyzer" at "200 MHz, DIN0...DIN23, DIO24...DIO31" it change sample rate "100...400MHz" -> "800 MHz" and change DIO24 -> DIN0. If start "Logic Analyzer" at "400 MHz, DIO24...DIO39" it change sample rate "100...400MHz" -> "800 MHz" and make DIO >= 32 "not available". And after that "800 MHz" -> "400 MHz" moves DIO32 -> DIO24 and DIO33 also to DIO24. With best regards, Mikhail.
  23. Is it possible to decode scope data using one of the "protocols"? I often need to analyze scope data as inverted UART data (e.g an RS-232 async serial signal).
  24. I will update this thread as I find any other software issues when using the Analog Discovery2 with the Cora board. I expect that I will continue to have Cora programming issues and if I find any resolution, I'll post.
  25. Hello! Just tested it with simplest settings (attenuation 1X, 50 ns/div, zero signal). Only offset on the screen is changed. Scope1 ... Scope3. 1. It happens only with second channel. 2. When offset is [-2.34V ... -1.76V]. 3. At the borders noise is like a rare peaks. At the center like as an ADC input is overloaded. 4. Peaks values are -7.6V & +7.6V. Scope4. 1. Offset -4V 2. But signal is not zero, it is +2V. So it became to the same "- div from the center". Peaks are -5.6V & + 9.6V -> shifted +2.0V. 1V/div, 2V/div, 5V/div - the same situation. Why I am so cycled about calibration. Scope1 LG offset is -0.325 V. Scope1 HG offset is -0.0296 V. Scope2 LG offset is -0.300 V. Scope2 HG offset is -0.0274 V. So signal -2V can be on the edge between "Low Gain" & "High Gain". But because offset is quite big (15% of ADC input, may be damaged?), algorithm can not choose the right gain and generates peaks on switching. By this theory lowest border of the noise is -2.35 V - 0.3 V = - 2.65 V. If signal lower then this it works fine with "Low Gain". A bit upper there is "gray, turbulent zone". And greater than -1.76V the stable zone of "High Gain". With best regards, Mikhail. peaks.dwf3work
  26. Hi @GeorgeMina, Yes, you may attach one Pmod to the top row of the 2x6 header and the other Pmod to the bottom row of the 2x6 Pmod host port; you will need to use a cable of some kind though since the Pmods won't both physically fit on top of each other, but there is nothing electrically preventing you from doing this. I am not familiar with the Nebula board you mentioned, but you should be able to program it such that each Pmod is controlled separately. I don't know if there are any nuances with this particular board that you would have to consider (such as the Pmod port is only compatible with SPI Pmods). Thanks, JColvin
  27. Most connectors have very short insertion cycle specifications; unless they are expensive and specifically made to endure a high number of insertions. Having made that statement I will say that I have to maintain at least 4 tower and 2 laptops to support all of the obsolete tools and drivers that I've accumulated and still need; and I have yet to identify 1 USB port that has gone bad. My main Win7 delvelopment PC is as old as, well.. Windows 7 is. It's not a bad idea to invest in a few USB hubs. They are a lot cheaper than PCs. There are reasons for doing this even if you aren't worried about connectors going bad. I recently destroyed ( well I haven't bothered to take the time to figure out what the problem is ) a USB HUB while developing a FT232H project ( this is a lot easier to do than you might think) ; glad that it wasn't one of my motherboard USB Host Controllers... I generally keep USB cables plugged into development boards when not being used. I've had a number of USB connectors rip off of such boards. In particular, if you have any development board with a USB connector lacking thru-hole shield ground tabs I guarantee that sooner or later it will come off with the end of your cable. One way to mitigate this is to apply some epoxy around the connector before using such a connector. I do this as a habit. I've found that most USB micro or mini cable connectors require a high insertion force, and that's if you are trying to plug it in correctly; some are worse than others. Zygot rule for the day: "Break cheap stuff, not expensive stuff". Corollary: "You are going to break something sooner or later". [edit] I should have specified that by USB HUB I mean self-powered USB HUB.
  1. Load more activity